Restart not permitted. Overwriting the file

I have a bad connection to an ftp server where I get disconnected every few minutes. I often need to upload some large files and I rely on the resume facility to complete the uploads. However, the server will keep the file open for a period of time after a disconnection and this is where a problem occurs. See this piece of log.

[14:24:15] REST 2060424060
[14:24:15] 350 Restart at offset 2060424060
[14:24:15] 451 Can't create file "A539657C.DAT".
[14:24:15] 0 bytes transferred. (0 bytes/s) (187 ms)
[14:24:15] Restart not permitted. Overwriting the file.

This is a major problem as every few reattempts, the file starts at 0 again and it never completes. It's got up to 2GB in this case after several restarts over several minutes, and then it's restarted at 0 again. It does this over and over again and never finishes uploading the file.

Is there some way to prevent this from occuring? I will never want a restart to occur in any situation. It is wasting a lot of bandwidth and basically the software is not working as I thought it would.


Your server does not resuming files. Please contact your web hosting provider for assistance.

Your server does not resuming files. Please contact your web hosting provider for assistance.
Yes it does. I only gave you one piece of a log where a resume failed. About 90% of all resumes resume correctly. The file would not have got to 2GB without resuming at least 10 times successfully.

The problem is SmartFTP thinking that "451 Can't create file " is due to the server not supporting resume, but that is an incorrect asumption. The server has simply kept the file open after the connection was interrupted. The server needs time to timeout and close the file before it will allow a resume to continue. SmartFTP needs to be a bit smarter.

I tried increasing the Connection and Retry timeout in SmartFTP but it didn't help. I purchased the software recently but I'm starting to reget that unless this can be fixed.

I know most people don't have real bad and flakey internet connection, but this must affect a few people occasionally. I hope something can be done. Even a simple option to disable restarts and only retry resumes would work for me.

Here is a part of a log where a resume succeeded.

[12:51:16] Remote file exist check: "A32457834.dat".
[12:51:16] SIZE A32457834.dat
[12:51:16] 213 5891752
[12:51:16] MDTM A32457834.dat
[12:51:16] 213 20080926125114
[12:51:16] Source File: Size=3775174656, SizeUnit=Byte, Time=2008-07-30T08:07:40, TimeFormat=Exact
[12:51:16] Destination File: Size=5891752, SizeUnit=Byte, Time=2008-09-26T12:51:14, TimeFormat=Exact
[12:51:16] RecentTime=2008-09-26T00:51:14
[12:51:16] No rule matched. Default Action="Resume".
[12:51:16] PORT 192,168,1,100,4,79
[12:51:16] 200 PORT command successful
[12:51:16] REST 5891624
[12:51:16] 350 Restart at offset 5891624
[12:51:16] STOR A32457834.dat
[12:51:17] 150 Opening BINARY mode data connection for A32457834.dat.


Post the system information from the menu: Help->About "System Information"

+- System -----------------------------
Microsoft Windows XP Professional
Service Pack 3 (Build 2600)

CPU Speed : 1954 MHz
Total Memory : 1535 MB
Free Memory : 771 MB

+- SmartFTP ---------------------------
Version : 3.0.1022.21
Time Stamp : 2008-09-07 05:52:16
Platform : x86
Id : 400074720
Days in use : 45

+- Application DLL --------------------
sfFTPLib.dll :
sfFavorites.dll :
sfFavoritesShellExtension.dll :
sfTransferQueue.dll :
sfFTPShellExtension.dll :
SmartFTPPS.dll : 3.0.1022.21

+- Language ---------------------------
SmartFTP.exe : 3.0.1022.21

+- Internet Explorer ------------------
Version : 6.0.2900.5512

+- Winsock ----------------------------
Winsock : 2.2

It appears my IE was using a cache of the previous file I downloaded. I finally managed to get the new one to download. I can't test it currently but will let you know if the problem persists.