Incredibly slow upload speeds

So, I've read through this forum and have seen multiple threads with the same issue... what are we doing wrong?

I've adjusted transfer buffers for optimal settings, but didn't see any results. I'm on a 10mb circuit, uploading to a server hosted with Mosso (division of Rackspace), and my transfer speed tops out at 9.8 KB/s.

Didn't have this issue in previous versions...

Thanks for your help and time, as always.


Do you have any kind of software firewall or antivirus products installed?

I'm assuming that you didn't change the KBs/Worker limit in the Transfer Queue from 0 to 10.


Can you post the system information from the menu: Help->About?

Do you remember which was the last version which was faster for you?


Thanks for the speedy reply

Here's the system info:

+- System -----------------------------
Microsoft Windows XP Professional
Service Pack 2 (Build 2600)

CPU Speed : 1862 MHz
Total Memory : 2047 MB
Free Memory : 2047 MB

+- SmartFTP ---------------------------
Version : 3.0.1019.8
Time Stamp : 2008-07-05 03:30:14
Platform : x86
Id : 400043284
Days in use : 297

+- Application DLL --------------------
sfFTPLib.dll :
sfFavorites.dll :
sfFavoritesShellExtension.dll :
sfTransferQueue.dll :
sfFTPShellExtension.dll :

+- Language ---------------------------
SmartFTP.exe : 3.0.1019.8

+- Internet Explorer ------------------
Version : 7.0.5730.11

+- Winsock ----------------------------
Winsock : 2.2

I don't remember the exact version, but it was 2.XXXXX...

What should the workers / KBps/Worker be?

I currently have 1 worker for one transfer at a random 3104 KBps/Worker (I just held the up arrow key for a while - no changes occurred).

Thanks for your help... I'll probably just go back to the earlier version...

If it's not broke, don't fix it... right?

It would be interesting to know why a new version should affect the transfer speed.

If you install version 2.5 please let me know if this fixed the problem and how much faster the transfers are.


Removed 3.0 and installed 2.5...

Uploaded the same 70mb file...

With 3.0 it took a little over 2 hours topping out at 9.8 kb/s

With 2.5 it took about 2 minutes topping out at 567 kb/s


Would you be interested to test some modified 3.0 versions if we provide them?


Sure... no problem. Happy to help - least I can do for all this free support!

Thanks. What protocol are you using? Standard FTP? or FTP over SSL?

Also if you prefer email, msn messenger etc please send an email to support at


Hello All,

Although I'm not sure what was done to fix this issue, I am now able to download at full speeds after I downloaded the latest version/build.

You can find it here...

Thanks to mb for working with me to resolve the issue!


Hello. I too am having difficulty with very slow upload speeds using the latest version of smartftp. I read through the forum and did exactly whatever advice was given. But, no change.

I wanted to remove the newest version on my computer and as instructed in an earlier thread, install version 2.5. Apparently that version is uploading at great speeds. Anyways, after removing the software and while attempting to install the 2.5 version I recieved the following message: "SmartFTP has encountered a newer version on this computer". Then the install shuts down. I rebooted my computer and tried again, but same result.

I only wish to upload my large files faster than 4-12k. I have 100mb potential.

Please help me understand why I couldn't install the older version and how to get around this.

Thank you very much!

To install a previous version of SmartFTP:
1. Uninstall the version you have currently installed (Start Button->Control Panel->Add/Remove Programs_
2. Reboot your computer
3. Install the old version