Drag and Drop Upload Awkwardness

I recently upgraded to 3.0 as my 2.5 expired. Now I cannot upload files by dragging them from Windows Explorer and dropping them in the Remote Browser. Neither the Folders pane or files pane. I've taken screenshots of exactly what happens. But, of course, this problem prevents me from uploading them.

I have updates waiting to upload to a local secondary school's website. Including last-minute changes for soon-to-be-held events! For SmartFTP to let me down at this moment is really disappointing as it's pretty much bulletproof most of the them.

Steps to reproduce:
  1. Start SmartFTP.
  2. Log into an FTP site with username and password.
  3. Navigate to a folder.
  4. Switch to Windows Explorer.
  5. Navigate to a folder you want to upload files from.
  6. Select the files and drag them over the files pane of the Remote Browser in SmartFTP.
  7. Cursor displays a + as you'd expect.
  8. Drop the files.
  9. A "Preparing to Copy" window appears.
  10. It's changes to display a different progress bar.
  11. A giant "Copy File" window appears with several strangely presented sections, inconsistent spacing, with some titles in title case, others in sentence case and sme sentences missing terminal punctuation.

    Anyway, the choices are:
    1. Copy and Replace
    2. Don't Copy
    3. Copy, but keep both files
    4. Use Automatic Rules
    Incidentally, the "Preparing to Copy" window remains behind the "Copy File" window. The progress bar is whizzing away frantically. Oh, and the opening instruction "Click the file you want to keep" is wrong since 2 of the items don't display a file. The final item doesn't even clarify which file it means by "The file". Urgh.
  12. Having never seen anything like this on Windows XP, it takes me a long while to figure out what it's telling me.
  13. I realise this is something that Just Worked in SmartFTP 2.5 by applying file replacement rules. Which I'd set to always replace the file in case of conflicts.
  14. So I click the "Copy and Replace" item.
  15. Instead of doing what I told it, an information bar appears in the file pane of the Remote Browser!
  16. It says: "The operation has been added to the Transfer Queue. To start or show the Transfer Queue, click here..."
  17. Erm, why is the Transfer Queue getting involved? SmartFTP 2.5 just uploaded and replaced files when I dropped them into folders.
  18. So I click the bar and it shows me a two-item context menu:
    1. Start Queue
    2. Show Queue
    Hmm, why hasn't it just shown the Transfer Queue? Can't you start it after you've shown it? Can't you show it after you start it? (I've since poked around and you can do both. So I think this context menu is worse than useless.)
  19. Transfer Queue duly shows itself, with one item. A folder called "c". Huh? I was dragging and dropping a file called "changelog.html", not a folder called "c"!
  20. "Source" and "Destination" for these entries was seemingly random locations.
  21. After retrying several times (hence poking around as mentioned earlier) this kept on happening.
I eventually gave up and had some lunch.

Started my machine up again and tried again. Much the same as above BUT now the entries in Transfer Queue are correct. So maybe SmartFTP needs a restart after an upgrade from 2.5 to 3.0 before everything will work properly?

But this situation remains MASSIVE FAIL in my eyes because:
  • The setting I'd carefully and deliberately set in SmartFTP 2.5 is being ignored in SmartFTP 3.0.
  • Transfer Queue, a feature I've never used, has gotten involved.
  • These windows are not all in keeping with Windows XP.
  • These windows use weird custom widgets and are frankly nothing but a pest.
I've checked the Default Favourite and my setting is present. In the "File Exist Rules" window, the "Default Action" is set to "Overwrite" just as it was in SmartFTP 2.5...so why isn't it doing that?

So yeah, I do actually adore SmartFTP (biggest compliment you can give an app is to use it daily) but the upgrade experience and default user interface is a serious and, sadly, growing weak point, imho.

(EDIT) Oops, forgot System Info:
+- System -----------------------------

Microsoft Windows XP Home Edition 

Service Pack 2 (Build 2600)

CPU Speed		   : 1410 MHz

Total Memory		: 511 MB

Free Memory		 : 201 MB

+- SmartFTP ---------------------------

Version			 : 3.0.1016.10

Time Stamp		  : 2008-05-22 20:40:49

Platform			: x86


Days in use		 : 382

+- Application DLL --------------------

sfFTPLib.dll		:

sfFavorites.dll	 :

sfFavoritesShellExtension.dll :

sfTransferQueue.dll :

sfFTPShellExtension.dll :

+- Language ---------------------------

SmartFTP.exe		: 3.0.1016.10

+- Internet Explorer ------------------

Version			 : 8.0.6001.17184

+- Winsock ----------------------------

Winsock			 : 2.2