Creating Backups

Hi, I just started with SmartFtp today and I love it!

My use for it is to backup our databases several times per day and have each backup to be saved uniquely and fully (not just files that were changed), and to not overwrite the previous download.

I've learned the scheduling features, but it just keeps overwritting the previous backup. I need it so each time the scheduler runs, it will create a new complete download like so.


This feature seems to be present for manual transfers, it prompts you so you can 'Copy and keep both files' and it appends each folder in a numerical sequence. But with scheduler I haven't been able to do this.

Please assist.


Mb can you assist with this?

How can we prevent overwriting of files using scheduler? I would like a new copy to be made on each scheduled download.

Best, Mike

Of course. Edit the transfer queue item you have scheduled. You can use the following variables for the destination file/folder:
// *a Abbreviated weekday name
// *A Full weekday name
// *b Abbreviated month name
// *B Full month name
// *d Day of month as decimal number (01 – 31)
// *H Hour in 24-hour format (00 – 23)
// *I Hour in 12-hour format (01 – 12)
// *j Day of year as decimal number (001 – 366)
// *m Month as decimal number (01 – 12)
// *M Minute as decimal number (00 – 59)
// *S Second as decimal number (00 – 59)
// *U Week of year as decimal number, with Sunday as first day of week (00 – 53)
// *w Weekday as decimal number (0 – 6; Sunday is 0)
// *W Week of year as decimal number, with Monday as first day of week (00 – 53)
// *y Year without century, as decimal number (00 – 99)
// *Y Year with century, as decimal number

So for example you would set the destination to:
C:\Downloads\My Folder *d.*m.*Y


Thanks for the tip. Although I tried it and it just produces this:

Folder _d._m._Y

It's not picking up the timestamp, and putting underscores instead.

PS: I'm using win server 2003


You are right. It's a bug. I have fixed it now. The bug fix will be available in the next build (~ 1 day).


Cool. Will I need to download and re-install or is there an update that can be run within the program?

Thanks for this. I actually came in here today looking for this problem before I posted. Glad I did; it's already fixed!

Hi Mb,

This issue has occured again. I'm only getting underscores instead of the date/time stamps. Any ideas?

All I'm getting is this:

Folder _d._m._Y


I forgot to mention this happened after I uninstalled my old version and then downloaded the latest build (4.0.1223.0). The date function stopped working at this point.

The old method has been deprecated. The new method is with a transfer queue item script:

The script you are looking for is the following:
Dynamic Transfer Queue Item Destination Path

Ok, i've installed the SDK and set the script. It's now creating new items in the transfer queue, but they are not processing. No matter what I do (clicking play, pause etc)I can't get them to download. I'd like to use this with the scheduler to download a full copy of our datbase every hour. When I remove the script it downloads just fine, with the expection of the destination path is always the same. When I put the script back in no download happens, it just creates new items.


Nope, there is nothing in the transfer log.