Ghost Folders

chrusion

2008-04-12 01:30:16

Why doesn't 3.01012.17 properly Refresh the directory structure after drag/dropping folders from the root into a new folder or after a forced manual refresh? Instead it leaves ghost folders and non-existence files/folders as shown in this image.

Image

I can disconnect and reconnect and the listing still doesn't refresh. Why?

See that "--------" folder? Well, it DOES NOT exist, but Smart?FTP still went a head and RENAMED it this "--------" that I typed in the rename dialog despite the ftp log saying the file doesn't exist!!!! I forget what it was originally named... I think "files"... yes, the name of the parent folder. What the.....!??

Same but different for the "filesz" folder... I actually RENAMED the main "Files" folder to "filesz" so that I could get the capital F to become lowercase, then renamed it BACK to "files" as shown in the right pane listing, but Smart?ftp made an "internal copy" and didn't rename the main folder. Too strange. Very disturbing behavior. Why?

Oh... and here's the actual contents of the root "files" folder, versus the left pane listing...

Image

mb

2008-04-12 01:31:32

Thank you for reporting. Can you describe what you are exactly doing to reproduce the problem?

Could you please post the system information from the menu: Help->About "System Information" dialog?

Regards,
Mat

chrusion

2008-04-12 01:47:37

What I did was login, change dir to /public_html, noticed that a collegue had created folders in this root folder and that the "Files" folder had a cap F, so I first renamed it to "filesz" with the added z because it wouldn't take the lowercase f, then renamed it back to "files" then dragged/dropped each of the out-of-place folders into the "files" folder, and refreshed by clicking the ( ) arrow icon. That's what I started seeing the ghosting.

So now all the folder as you see in the smaller image above are properly located in the properly named "files" folder as shown in the right pane, but errantly displayed (or not at all displayed) in the left tree pane.

+- System -----------------------------
Microsoft Windows XP Professional
Service Pack 2 (Build 2600)

CPU Speed : 2589 MHz
Total Memory : 2047 MB
Free Memory : 1094 MB

+- SmartFTP ---------------------------
Version : 3.0.1012.17
Time Stamp : 2008-04-10 14:29:55
Platform : x86
Unlicensed
Days in use : 0

+- Application DLL --------------------
sfFTPLib.dll : 1.5.12.43
sfFavorites.dll : 1.0.8.17
sfFavoritesShellExtension.dll : 1.0.1.9
sfTransferQueue.dll : 1.0.5.17
sfFTPShellExtension.dll : 1.0.3.17

+- Language ---------------------------
SmartFTP.exe : 3.0.1012.17

+- Internet Explorer ------------------
Version : 7.0.5730.11

+- Winsock ----------------------------
Winsock : 2.2

mb

2008-04-12 01:59:01

Thank you. We will fix it.

chrusion

2008-04-12 02:28:46

You are very much welcome! Great to have such a readily available dev monitoring their forums.

ETA on the next build release?

mb

2008-04-12 03:03:56

It should be ready by Monday. I will reply here as soon as it is.

mb

2008-04-12 11:05:58

Hello ..

The new version is available now:
https://www.smartftp.com/download

We have fixed two bugs related to your problems. Please give it another try.

Thank you
Regards,
Mat