What happened ?

never mind,overlooked it . . . will post additional info . . .

Did you already completely remove any 2.5 copies to upload from site? . . . bad move, everything in 2.5 worked fine!

V2.5 was fine - why force an upgrade to v3? When I fired up smartFTP it told me it had expired and my only choice was to upgrade to V3. I tried to reinstall v2.5 but no luck, so I went from perfectly good software to a dead application in the time it took to click "ok". I had to upload a file (3min job) to my web site - and spent over an hour doing so. I finally manged by loading FTP neighbourhood on my PC !

as per the other reports, v3 has an upload bug which makes it unusable. I was able to connect to the FTP server and deleted the target file ok (smartFTP wouldn't overwrite) dragging and dropping refused to work - the file is reported in the FTP command log as not existing on the local PC (when in fact it does and can be opened by other apps). The file gets added to the queue but never uploaded.

The machine was running XP SP2.