File transfer stops - to many connections


I have a problem.
Yesterday I connect to a FTP (from my webspace) and upload some files (round about 20, 50 ...something like that). It works properly good and fast. No problems.
Today I want to upload some files again (same directories, same files). First of all it seems to work, it started, asking for existing files (I choose "all" and "replace").

But afters it started and upload some files (3, 4 or 6 max) it stopped working. It seems that it can´t get the next information for uploading the file, waiting and waiting and than getting a timeout.

I looked in the log and see, that smartFTP use a new port for every file. Is this normal???
I think there is no requirement for use only one port for one file.

I search the database on the website, read the help. I changed from Passive Mode to Active Mod and vice versa. It always worked after few minutes (directly after the problem I can´t reconnect). But than the same problem appears again.

Than I saw at least in the log file the message: "421 Too many connections (5) from this IP".
No wonder, when smartFTP opens for each file one port, then after 5, 10 or 50 Files you have 5, 10 or 50 Ports opened to the same server. Every normal server will refuse that to defense attacks and problems.

I don´t understand it.
Maybe someone can help me. I don´t how prevent smartFTP from open one port for one file. There must be a way to use one connection via one port for all files until the last is uploaded. Or not??

And: I don´t change any settings from yesterday to today neither at smartFTP nor on my router (and yesterday it worked properly).

My System (this maybe helps):
- notebook (via WLAN)
- outpost firewall pro (I deactivate it, but this doesn´t helped)
- netgear router (there is full access from inside to the internet, I also have UPnP activated for smartFTP and at the router)
- 100Mbit/s connection to the internet with fix IP
- Windows XP
- Windows FW is disabled

Your assumptions are mostly wrong.

The problem is very likely with your NAT router. It doesn't seem to forward the connection close packet (FIN) to the FTP server. If you want us to look at your problem please purchase a license at: