Cannot open SmartFTP

Hello there,

i have been using the SmartFTP Client for few months now.
Yesterday and today i was not able to open the SmartFTP. I get the window saying 'Your SmartFTP built is about to expire. Please buy or upgrade...' I tried to upgrade but still cannnot open it. The moment I click OK the window just disappears.

Do i have to buy the licence or is there anything i am doing wrong (i'm not very techie ?

Please could someone help me.

Many thanks


I've had similar problems, but installing the latest version always fixes it.

I've had to run the install a few times every time I do it for it to take...not sure why...

Many thanks to you all for your replies. I kept downloading the programs few times and it's all working now. Many thanks.

I've had the same problems in various systems.

Now it has occured again. Can't open SmartFTP, it exits immediately after the upgrade/buy dialog.

The fact that this is a recurring problem, and has been for quite a while, is the main reason I've been hesitant to purchase it.

Even though I use it for personal non-commercial purposes I've been all willing to pay for applications I use, but not if the cease to function every now and then.

Just downloaded latest version ... it didn't help.

That's it for me - no more SmartFTP (too bad, I really liked its GUI when it worked).

The reason the expiration dialog is displayed because you have not purchased a license yet. If you purchase a license the expiration dialog will no longer be displayed. To purchase a license go to:


Well bu&&er me! I finally got it reinstalled after several attempts and guess what? The version I had to upload was the same version I already had

Why do we have to upload a "new" version from the purchase screen when there is a perferctly good dropdown menu containing a link to upgrades - which I check for on a regular basis? Is this something to do with the timer display of how long I have been using it? Even though it is free for my use? And, NO, I do not want to hear the tried and tested excuse thank you very much!

No wonder pirates proliferate


Same problem.

SmartFTP stopped working.
Followed the bouncing ball to upgrade.
Still didn't work (exited after complaining I had to upgrade or buy). So much for that free licensing for personal use.
Searched on the 'net. Found this thread.
Downloaded the provided link.
Now SmartFTP will run/open but immediately crashes as soon as I try to upload. Yay!

Let's see...I only use 2 FTP sites. The last build stopped working with 50% of those sites. Then it simply stopped running. So I was forced to upgrade to a version that simply doesn't work.

Yeah, that's something I really want to buy. *smirk*

Back to DOS FTP for me. It ain't pretty. But it works. Consistently.