Avoid showing file on directory before it is transfered?

Hi .
Is there a way to avoid smartftp showing the file I am transfering before it its fully transfered?
I ask this cause when I am working and I transfer a file from my ftp to my pc , it will automatically appear on my folder even thought is transfering, so I get the problem that I dont realize it still transfering and I open the file making it corrupt .
I have lost lots of files this way . hope there is an option for this.