Compression and private ip

How can you enable compression for servers with a private ip address?

If that option does not exist, I'd consider this a bug, because the ip address is not a reliable way of deciding whether you are on a fast local network or not. For example when you use SmartFTP over a (Open-)VPN connection over the internet.

Hello ..

1. menu: Tools -> Settings
2. In the Settings dialog go to the Favorites dialog.
3. Click on Edit Default Favorite
4. In the Edit Default Favorite dialog go to the Transfer -> Compression dialog
5. Uncheck the [x] Disable compression for local addresses option



I only looked in the settings for that particular connection (not the default favorite), but that checkbox is missing there...

Yes the option is not there because we think it's redundant.