failed to save transfer queue

[codebox]+- System -----------------------------
Microsoft Windows XP Professional
Service Pack 2 (Build 2600)

CPU Speed : 597 MHz
Total Memory : 255 MB
Free Memory : 85 MB

+- SmartFTP ---------------------------
Version : 2.5.1006.4
Time Stamp : 2007-06-08 18:41:59
Platform : x86

+- Application DLL --------------------
sfFTPLib.dll :
sfFavorites.dll :
SmartHook.dll :

+- Language ---------------------------
SmartFTP.exe : 2.5.1006.4

+- Internet Explorer ------------------
Version : 6.0.2900.2180

+- Winsock ----------------------------
Winsock : 2.2

Somewhere around the time when I updated to a version that changed the way the favourite list is stored, my client became unable to save my (global) transfer queue. The 'automatically save trf q' setting is on, interval set to the default 10 mins. After an exit+restart the transfer q is always empty. Pressing the 'save' button on the transfer queue panel returns an error message: failed to save transfer queue.

My client is set up in a way that the settings, backup and favs folders are located under the clients install directory: .\settings, .\settings\favorites, .\settings\backup, and it's configured for only 1 user, me. I tried to uninstall the updated SmartFTP, cleared the HKCU\Software and HKLM\Software reg branches of SmartFTP entries (if there were any, I don't remember), then reinstalled the newest (current) client. This didn't help. I tried to switch off the auto save function, restart, switch on, restart, to see whether these changes needed a restart - no change. AFAI remember after updating from the older version, which stilled stored the favs in a file, I saw a file named 'Transfer Queue.xml' or sg similar in the settings folder, however since clearing and reinstalling it hasn't appeared anymore. I tried creating an empty file with that name, and also putting the default 87 byte long 'empty' xml into the settings folder but that didn't change a thing. I don't remember which version I had was last able to save the queue, sorry if that's relevant.

I hope it's just user error.

Hello ..

Go to the Transfer Queue window. Click on the Save As .. button. Select a folder to save the Transfer Queue.xml to.


Ah, how could I have missed that little arrow! I feel a total noob now.

Thanks for clearing it up. And as for moving the thread, thanks for that too. Initially I was pondering where I should post, then somehow the bug thread won.