All OK in SmartFTP but nothing on my webpage.

Everything appears to be correct in SmartFTP but my webpage is still displays "Hi my website is not ready yet."

[11:53:05] 200 Type set to I.
[11:53:05] REST 0
[11:53:05] 350 Restarting at 0. Send STORE or RETRIEVE to initiate transfer.
[11:53:05] PWD
[11:53:05] 257 "/backup/home2/users/enteh" is current directory.
[11:53:05] CWD /backup/home2/users/enteh/public_html
[11:53:05] 250 CWD command successful.
[11:53:05] PWD
[11:53:05] 257 "/backup/home2/users/enteh/public_html" is current directory.
[11:53:05] TYPE A
[11:53:05] 200 Type set to A.
[11:53:05] PASV
[11:53:05] 227 Entering Passive Mode (203,29,124,1,225,64)
[11:53:05] Opening data connection to Port: 57664
[11:53:05] LIST -aL
[11:53:05] 150 Opening ASCII mode data connection for '/bin/ls'.
[11:53:05] 226 Transfer complete.
[11:53:05] 307 bytes transferred. (6.37 KB/s) (47 ms)

I managed to find the folder public_html, I loaded the files into this.
I tried direct and queued upload, the message said transfer complete.
This is the web page my ISP gave me,

Hello ...
You have to replace the index.html with your own.

Hi matt,

I am using Nvu to create files and don't seem to be having any trouble uploading now, but the way the web page displays is still not right. I dropped a file in the index.html and this is what I got.

Index of /~enteh

Name Last modified Size Description

[DIR] Parent Directory 25-Apr-2007 09:58 -
[DIR] index.html/ 25-Apr-2007 09:59 -

Apache/1.3.34 Server at Port 80

You have created a directory called index.html. What you actually need is a file which is called index.html:
1. Delete the directory index.html
2. Create a file called index.html (New File)


That worked.

Does this mean any file I name index.html and upload will be my opening web page ?