Upload has suddenly stopped working

I've been using SmartFTP for just over 30 days to create my website and it has worked fine until yesterday. Now when I try to upload (I usually do it direct to folder) it places the file in the Transfer Queue and keeps trying to upload from there but without success.. I've noticed that all my folders have Permissions set to 755 with Read, Write and Execute allowed for User and lesser permissions for others. The public_html folder is set at 0, with no permissions. I don't know whether this is as it should be as I have not looked before my problem. I did try setting it to 755 but all it seems to go through is a refresh then it sets itself back to 0. Am I missing something? Any advice appreciated, cheers in advance.


I've been trawling thru previous posts and this seems a common prob which no one has answered yet. The prob must be with smartftp as I've tried trellians trial ftp and that works. I've also found the prob only applies to the base directory ie. public_html. I can upload to lower level directories and then if I need a file/folder to be put in 'public_html' then I can move it up from a lower level. (ie. on the remote server) Not satisfactory but it does work. Is Smartsoft trying to make us purchase the product by putting a bug in the free version which kicks in after 30 days? I was considering buying it as I've been thoroughly impressed up until my problem. Although these forums are a good idea I don't see many of the probs being resolved, it seems the majority of the posts are from new users with probs like me. I suppose experienced user don't need the forums.

Final note.
Reinstalling SmartFTP resolves the problem so I suppose for a free package it is worth doing this every 30 days. I'll carry on using it.
I was disappointed at the lack of response on this forum, over 100 views and no replies (except my own, but then I'm used to talking to myself!)