FTP Folders and files do not list

I have a problem (bug?) when I log onto one of the FTP servers I use where the folders and files will list if I FTP via Explorer, and via FTP in a Windows' command prompt but not with SmartFTP.

The Raw listing gives me an empty page. I can log into other FTP servers without a hitch, it feels like some configuration setting but (I think) I've tried them all.

Here's the log

[16:41:13] SmartFTP v2.0.1000.2
[16:41:13] Resolving host name "ftp.7thdirection.com"
[16:41:13] Connecting to Port: 21
[16:41:14] Connected to ftp.7thdirection.com.
[16:41:14] 220 FTP server ready.
[16:41:14] USER xxxxxxx
[16:41:14] 331 User name OK, need password.
[16:41:14] PASS (hidden)
[16:41:14] 230 User logged in.
[16:41:15] SYST
[16:41:15] 215 MACOS WebSTAR FTP.
[16:41:15] Detected Server Type: MacOS
[16:41:15] TYPE I
[16:41:15] 200 Using binary mode to transfer files.
[16:41:15] REST 0
[16:41:15] 350 Requested file action pending further information.
[16:41:15] PWD
[16:41:16] 257 "/" is the current directory.
[16:42:06] NOOP
[16:42:07] 200 NOOP OK.

FWIW - I downloaded and tried WinFTP and it has the same problem that SmartFTP so it really feels like a setting somewhere is wrong. If I can find out what to tell the webmaster for the Server that would be helpful.

I'm on XP Sp2, all the updates and am using OneCare as my security. It would be GREAT to be able to use SmartFTP but for the time being I'm resigned to using Explorer. (yuck)



Hello ..

Your log is incomplete. It misses the directory listing attempt (LIST/MLSD).

Hello ..

Your log is incomplete. It misses the directory listing attempt (LIST/MLSD).

What you see is what I get. I never get a directory listing - just the NOOP message over and over again. I've turned on all List options, to no avail.

If you have any suggestions as to settings, feel free to offer.

Press F5 or click the Refresh button in the toolbar.