Show seconds from a file timestamp

it seems to be a common problem that FTP transfers cannot show the seconds of a file's timestamp. I'm running ProFTPd on my webserver and it doesn't send out timestamps including seconds by default. But I am able to alter the LIST line format so that it contains a different timestamp format, also with seconds. Only as soon as I try that, SmartFTP (and other FTP clients) don't show any file in the directory, it's like empty. Since the FTP RFC doesn't specify the format of such listing in any way but rather says that it's meant for human readers and may not be parsable through software, I'm wondering what formats SmartFTP understands and how this can be implemented on the server side. Also, it seems that SmartFTP doesn't even contain the window space to show seconds, the time stamps are only displayed as "$SHORTDATE HH:MM" with not even a ":00" at the end of the timestamp for the seconds.

Hello ...

I would recommend you a FTP server which supports MLSD/MLST. MLSD is also known as a machine readable format. All modern FTP servers should support it.
Proftpd planned to support MLSD/MLST for a while now but nothing has happened.

>Remote Browser
The remote browser tries to mimic the behavior of the Local Browser / Windows Explorer. If you find a way to enable the seconds in the Windows Explorer we will do it as well.
In the latest beta version the seconds are displayed in the File Properties dialog.