Problems uploading animated GIFs


May problem was the following (please go ahead to understand, why I do this posting anyway): I created an animated GIF, which ran pretty well in my local environment (FireFox & IE). But when I uploaded it using SmartFTP the GIF won't be animated again. Heh? I tried it several times, reloaded the page, deleted all files on the target drive aso. Nothing worked

So, first I wanted to report this strange SmartFTP behaviour, that I did not understand. First... Then I was trying to find related topics in that forum and I found one of interest for me. It had nothing to do with my problem. It was about the compatibility of SmartFTP and FireWalls. Then I said to myself "Just disable ZoneAlarm and try out (because it was so often the source of obviously non-logical behaviours)". And: the wonder happens! IT WORKED!

So why do I post this thread anyway? Because I think that this could be interesting for other people who are already driven nuts by this or a similar behaviour. In fact it seems like ZoneAlarm removes the GIF embedded "intelligence" of the animation somehow and it arrives finally on the server just as a quite ordinary GIF. Please don't ask me why, but it works and I hope that my experiency helps others.

Cheers, Alf.

P.S.: By the way: other FTP-progs that I checked out (i.e. WinFTP) had the same problem...

Thanks for your sharing your experience. Personally I would recommend to stick with the Windows Firewall. It works flawless with any products we have tested and it offers sufficient protection for most users.