JPG files curiously corrupted on upload


My wife and I both use websites to provide online resources for college courses we teach. I've been using Dreamweaver to prepare and upload my sites for a year or two but my wife has just begun to use websites. I hoped the Client would help her to master website construction---in fact she and her student assistant both quickly got the hang of the Client interface---but she has a major problem uploading JPG images.

I downloaded and installed the SmartFTP Client v.2 on our two office machines and on our two home machines back in September.

The Clients on the two office machines are working well and the Client on my own home machine also seems to be working well but the Client on my wife's home machine corrupts JPG images larger than thumbnail size (2kb) during uploads. My home Client always succeeds with the same files and the same FTP destination. As far as I know we are using the Clients' factory default settings. We always use the transfer queue.

Our home network uses a Linksys BEFSR 41 four-port router attach to a cable modem. Both home machines are Dell Dimension 3000s purchased at the same time and both running XP Home. After using net resources to test the Linksys router's firewall protection I turned off the XP firewall on both machines. I have no port forwarding at home. Otherwise we've both have full, simultaneous access to the net and no obvious problems.

Does this sound like a familiar issue to anyone? How can I resolve it?


Okay, the situation is now less curious.

At home I routinely connect to my university's network through VPN but my wife does not. When I am not connected by VPN, my SmartFTP Client has the same problem as my wife's: JPG files larger than thumbnail size arrive corrupted at the FTP destination. (So far we only upload JPGs, HTM, and PHP files. None of the HTM and PHP files are really very large.)

By corrupted I mean that some of the JPGs are truncated though some are not but everyone has color flaws---horizontal lines with the wrong color---throughout.

I'm guessing that the VPN encryption(?) is actually protecting the file sizes and image data before it leaves our machines.

So I'm also guessing that without the VPN both our home SmartFTP Clients have some more standard problem, perhaps with our Linksys BEFSR41 router. How do I troubleshoot this?

(We will use the VPN but we'd like to know how to use your tools properly!)

Thanks again,



My wife and her student like smartftp and my wife doesn't want to deal with my VPN connection at home, so I've continued to seek some fix for the truncation-and-corruption issue.

I first searched back through the smartftp forum to see if anyone else had reported this problem. Liem Do on Aug. 2, 2006 reported a similar issue, and eyebx (root admin, Aug. 4) suggested using the queue manager. We had been doing that when we noticed the problem. Then in the same thread started by Lien Do and responded to by eyebx, another user, Goose on Oct. 13, 2006, reported the same issue, which sounded like our problem exactly. Goose's client was trying to upload a bunch of PDFs and they were arriving empty or damaged.

Another user, Xurch, Oct. 10, reported that his web host set upper limits on transfers. Our host gives us 600gb storage and supports 5,200gb transfers. And in our case, smartFTP always reports that the uploads succeed.

L10Elton, last message Sept. 26, 2006, started a long thread about the "filesize mismatch" message, which seems relevant. However we never see that error message even when the JPGs appear to be truncated. So maybe the the right number of bytes get sent but they are corrupted somehow.

By that time I was on page 11 of the Public Forum archive and felt no wiser.

I wanted to verify that our router was the source of the truncation-and-corruption problem.

Our web host advises its clients to use either smartFTP, ws_ftp, or cuteftp, so I downloaded ws_ftp and tried it. I expected that I would see a similar disruption of the ftp_transfer, then I would be able to effectively troubleshoot the Linksys angle. (Prior searches of Linksys forums had turned up nothing related.)

I turned off the VPN connection to school and ran the upload through ws_ftp.

Well, ws_ftp worked without extra effort, the first time out.

So, I wonder, I've looked at the smartFTP tutorials and I've walked through the uploads with the tutorial running. How would you prepare to transfer a folder of around 20-25 JPG files ranging in size from 60kb to 225kb? Assume no VPN. We don't mess with passive mode or binary/ascii controls on the smartFTP client.

Thanks for any advice,


The SmartFTP team is able to find a solution for your problem. But unfortunately we cannot offer these services for millions of free users for free. If you would like to have a qualified person to look at the problem please purchase a license.