Problem transfering swf file

I only know how to upload in this program so when something doesnt upload I have no idea what the problem could be.

I try to upload "Discworld.swf" an ordinary swf file and the transfer fails.
Ive tried checking and unchecking the keep file time boxes but no difference, unticking them solved the problem last time but I dont understand how.
I get this message on my log:

[20:01:02] Remote file exist check: "Discworld animation.swf".
[20:01:02] SIZE Discworld animation.swf
[20:01:02] 550 Discworld animation.swf: No such file or directory
[20:01:02] File size check (SIZE) failed. File not found or permission denied.
[20:01:02] PASV
[20:01:02] 227 Entering Passive Mode (64,27,0,199,192,96).
[20:01:02] Opening data connection to Port: 49248
[20:01:02] STOR Discworld animation.swf
[20:01:02] 150 Opening BINARY mode data connection for Discworld animation.swf
[20:01:19] 520192 bytes transferred. (30.9 KB/s) (00:00:16)
[20:01:19] 426 Transfer aborted. Operation not permitted
[20:01:19] Transfer failed.

I get this error message with anything I try and send. I'm not sure what causes it.

I just found out its because my host wont allow anything above a 500kb upload for swfs on free account.
So thats why some are working and the others are not.