Can't get to directory

Hopefully this isn't a stupid question, but I did search for answers before posting, and came up with nothing.

My problem is simple. After logging into the FTP host I want, the directory I need is actually called "\files". However, when I put the directory in, SmartFTP automatically changes the directory to "/files" which of course ends up not found. I looked throughout the settings to turn that auto-feature off, but found nothing. Any suggestions?

Thank you very much.

On FTP servers Unix style path (with "/" as a delimiter) instead of Windows / DOS paths (with "\" as a delimiter) are used, so SmartFTP's conversion is correct (a good FTP server should be able to handle both, anyways). So the problem has to be with the name "files". Where do you enter that directory? In the favorite settings under "Path"? Try just using "files" with no slashes at all.

the actual directory is "\files\taf", if that makes a difference

I can access the directory with other FTP clients (Cute FTP), but I would really like to use Smart FTP, since I use it for almost everything else.

Post the complete log of your FTP session.

Thank you.


You can use the command line and enter "CWD \files". The Menu -> Command -> Change Directory function automatically converts the path you enter to the server path style.

As we can see from the log your "elephant" FTP server is the cause of the problem:

[11:42:07] CWD \files\taf
[11:42:07] 250 CWD command successful.
[11:42:07] PWD
[11:42:07] 257 "/files/taf" is current directory.


Ok, you just lost me. LOL

So is the server the problem, or can I do something to work around it?