File Exist rules

I have a direct transfer file exist rules as follows:

IF Destination Size=Equal AND Time=Equal AND Transfer=Upload THEN Skip

But if I upload a file which matches that criteria, by selecting the local file and clicking the 'upload' button between the local and remote panes, a dialog still comes up asking me to decide. The dialog itself confirms that file size and times are equal.

MDTM is supported by the server and used by the client.

[08:58:22] Remote file exist check: "tender.asp".
[08:58:22] SIZE tender.asp
[08:58:22] 213 125285
[08:58:22] MDTM tender.asp
[08:58:22] 213 20060719045817
[08:58:22] No rule matched. Default Action="Ask".

Time=Recent in the exist rule produces the same result.

Am I doing something wrong, or should this be a bug report?

+- SmartFTP ---------------------------
Version : 2.0.997.0
Time Stamp : 2006-07-19 18:51:08
Platform : x86

Where exactly did you add the File Exist rule?


I just tested it. I couldn't find any problems:

[11:15:54] Rule "IF Destination Size=Equal AND Time=Equal AND Transfer=Upload THEN Skip" matched. Action="Skip".
[11:15:54] Skipping file "_mwstfrm.vts". Reason: User action.


I've noticed that the rules apply OK when using the Queue, so I've switched over to using that instead of Direct. Aside from that, I hope these are useful to you.

Additionally the server also supports XCRC hash check. I can only assume that the Direct transfer method does not make use of it. Another reason to use the Queue instead, I suppose.





Also check the settings in the favorite item. Make sure it uses the global "File Exist" settings.

The "Direct" transfer method doesn't support CRC, thats correct.


Use global settings is selected for this favourites entry.

The problem has been caused because the local file time has a higher precision than the remote file time. The precision of the local time is in milliseconds, the remote time only has a precision of seconds. As a result the local and remote time were never considered equal.

The latest version of SmartFTP (2.0.997.4) fixes this issue.

Thank you for pointing this bug out.


Excellent! Fix confirmed for my case.

[16:21:39] Remote file exist check: "tender.asp".
[16:21:39] TYPE I
[16:21:39] 200 Type set to I.
[16:21:39] SIZE tender.asp
[16:21:39] 213 124915
[16:21:39] MDTM tender.asp
[16:21:39] 213 20060726031905
[16:21:39] Rule "IF Destination Size=Equal AND Time=Equal AND Transfer=Upload THEN Skip" matched. Action="Skip".
[16:21:39] Skipping file "tender.asp". Reason: User action.
[16:21:39] Transfer successful.

+- System -----------------------------
Microsoft Windows XP Professional
Service Pack 2 (Build 2600)

+- SmartFTP ---------------------------
Version : 2.0.997.4
Time Stamp : 2006-07-27 03:40:58
Platform : x86


Thanks for this great Tool and the Forum!!

To this topic: No, still not solved exact:

On my side it still does not work:
- Login to *
- download a file
- download it again to the same place: Overwrite is asked and Files have a time-difference of 1 Second.
- tried it with 16 Files: 5 everytime ask for confirmation

I think there is still a bug when 1.5 milliseconds becom 1 second or 2 seconds...

Suggestion: in "File exist rules" -> "Time options" add "allowed Time difference in Seconds: [1]" (or also milliseconds)

Have a nice Day!


Hello Bruno ..

Please post the log. Also include the raw listing of the remote directory.
Can you reproduce the problem with a public FTP server?

Thank you.

Hi Mat

Sorry I forgot this thread since I did not enabled "[x] Enable email notification of replies? ".

The error happened on the public server, but this server is down for reinstalling cPanel...
I tried it also on ( but here the error does not occur...

I will continue this thread if I find another public server with this error or will reopen and still have the problem...

Thanks anyway!