"USER fireID@host" option missing

My corporate firewall requires the "USER fireID@host" option when using FTP. That option is missing from the proxy types offered by SmartFTP - the closest I see is "USER User@fireID@Host" and that doesn't work. Any way you could include it?

Yes .. just download and install the version from the link I've posted and test it. We would appreciate your feedback.

Works fine now. I am not sure what kind of a firewall my company uses, but I have seen "USER fireID@host" requirement working for large companies before, so this addition to your software id pretty valuable. Thank you for such a quick addressing of the request.


I'm not sure this is the right place to put this question, but this topic seems to be the closest to my problem.

I have to use FTP trough a FTP proxy with the type "USER User@Host FireID"; it works fine for all my FTP accounts except one. The point with this last account is that its login contains the @ char So have I thought that the connection error may come from this detail...

If I'm right, is there a way in SmartFTP to fix it?

Anyway, thanks for this very nice client!

Blue Duck

Hello ..

I think the @ in your username when not encoded just doesn't work with the FTP Proxy: USER User@Host FireID syntax.

Does this work with any other FTP client? Or what would be the correct way to encode a @ in the username?



Well... I suppose that "encoding the @" could work, if I knew how to do that
Going to query Google, but if you the answer...

Have a good day,

Blue Duck

%40 == @

Thanks, Aokromes
But not better: my login is still not accepted.
I tried to protect it with quotes, same error.

I can't believe that this problem has no solution. Trying to find documentation about FTP proxie...

Blue Duck