Files won't show

raikko

2006-03-14 16:53:54

Hi,

I have a problem with 1 FTP server : files and folders simply don't show. If I type the path, then SmatFTP finds the directory, but the files in this directory do not appear either...

Now, if I use Internet Explorer to browse the server, it works...

What's the problem ??? I've tried both passive and active modes.

here is the log:
[17:46:20] SmartFTP v2.0.995.15
[17:46:20] Resolving host name "62.210.XX.XX"
[17:46:20] Connecting to 62.210.XX.XX Port: 21
[17:46:20] Connected to 62.210.XX.XX.
[17:46:20] 220 awaiting input
[17:46:21] USER XXXXXXXXXX
[17:46:21] 331 Password required for XXXXXXXX.
[17:46:21] PASS (hidden)
[17:46:21] 230 User XXXXXXXXX logged in.
[17:46:21] SYST
[17:46:21] 215 UNIX Type: L8 - EFTP3 Server v3.1.4.84
[17:46:21] FEAT
[17:46:21] 211-Extensions supported:
[17:46:21] SIZE
[17:46:21] MDTM
[17:46:21] PUBK
[17:46:21] GETK
[17:46:21] 211 END
[17:46:21] TYPE I
[17:46:21] 200 Type set to I.
[17:46:21] REST 0
[17:46:21] 350 REST supported. Ready to resume at byte offset 0.
[17:46:21] PWD
[17:46:21] 257 "/D:/abcdefgh/xyz/" is current directory.
[17:46:21] CWD /D:/abcdefgh/xyz/
[17:46:21] 250 CWD command successful. "/D:/abcdefgh/xyz/" is current directory.
[17:46:21] PWD
[17:46:21] 257 "/D:/abcdefgh/xyz/" is current directory.
[17:46:21] TYPE A
[17:46:22] 200 Type set to A.
[17:46:22] PASV
[17:46:22] 227 Entering Passive Mode (62,210,XXX,XXX,42,127) .
[17:46:22] Opening data connection to 62.210.XXX.XXX Port: 10879
[17:46:22] LIST -aL
[17:46:22] 150 Opening data connection for directory list.
[17:46:22] 39 bytes transferred. (500 octets/s) (78 ms)
[17:46:22] 226 File sent ok
[17:47:13] NOOP
[17:47:13] 200 Ok. Parameter was ''.

xxxxxxxxxxxxxxxxxxxxxxxxxx

Thanks for your help!

mb

2006-03-14 17:12:46

Try to remove the -al switches from the LIST command by changing the directory listing optins in the Transfer settings. Then if it still doesn't work, right click on the folder and select "Show Raw Listing". Then post the raw listing here. Next time search the forum because your questions has been answered multiple times already.
Regards,
SmartFTP