Preserving File Dates

How do I preserve file dates during transfer? I did a search of the knowledgebase and the forums but found no specific mention of how to do this. I have searched through all of the options in Smart FTP v. 2.0.993 but couldnt find it. Thanks in advance for your help.

Edit: Sorry about the misspelling of preserve in the sub-title. Apparently it cant be editted.

File dates can only be preserved when downloading to your local machine (see the settings under "Transfer" -> "Files"). This is because only very few FTP servers actually offer FTP command to set / adjust a file's date.

Answer is not fully correct. If the server supports MDTM to set the file time the filetime is preserved for uploads as well.


Ah, good to know. I should note this for the docs :-)

Just to know it:

The Transfer -> File -> Keep File Time switch works, but only after exiting and restarting Smart FTP (build 1.5.991).

Please keep in mind that SmartFTP 1.x is no longer supported, though.