The files I'm uploading to my server are stating the directory does not exist?

I'm trying to transfer files to my server and everytime I go to retrieve the file where I uploaded it to it says File Type: street songs: can't stat `street songs' (No such file or directory).
I've tried other files and it says the same and some show fine but the majority are saying this. Any suggestions? I also posted the log. Thank you in advance for any suggestions?

[15:55:34] 226 20.584 seconds (measured here), 13.28 Kbytes per second
[15:55:34] SIZE street songs #14 blow up.jpg
[15:55:34] 213 279891
[15:55:34] Transfer successful.
[15:55:34] TYPE A
[15:55:34] 200 TYPE is now ASCII
[15:55:34] PASV
[15:55:34] 227 Entering Passive Mode (205,234,193,149,174,40)
[15:55:34] Opening data connection to Port: 44584
[15:55:34] MLSD
[15:55:34] 150 Accepted data connection
[15:55:35] 5696 bytes transferred. (22.2 KB/s) (250 ms)
[15:55:35] 226-Options: -a -l
[15:55:35] 226 45 matches total

Probelm solved.. It was a problem on my host/server side. They said that they didn't allow spaces in the file name. I tryed it and it worked.

Have a great day cause I know I am now.