Cannot download files with Norwegian letters

I am able to download files with "normal" names, but not those with letters specific for the Norwegian language. See the log for an example. How can I solve this? (Using SmartFTP v2.0.995)

[17:01:00] SIZE st

Your server is probably not configured for UTF8 encoding. Please post the log from the beginning to we can see which server software you are using.

Here's the log from the beginning of the connection:

[19:34:24] SmartFTP v2.0.995.3
[19:34:25] Resolving host name ""
[19:34:25] Connecting to Port: 21
[19:34:25] Connected to
[19:34:25] 220 (vsFTPd 2.0.1)
[19:34:25] USER s121058
[19:34:25] 331 Please specify the password.
[19:34:25] PASS (hidden)
[19:34:25] 230 Login successful.
[19:34:25] SYST
[19:34:25] 215 UNIX Type: L8
[19:34:25] FEAT
[19:34:25] 211-Features:
[19:34:25] EPRT
[19:34:25] EPSV
[19:34:25] MDTM
[19:34:25] PASV
[19:34:25] REST STREAM
[19:34:25] SIZE
[19:34:25] TVFS
[19:34:25] 211 End
[19:34:25] PWD
[19:34:25] 257 "/data/home/lu/alu/s121058"
[19:34:25] CWD /data/home/lu/alu/s121058/Mine dokumenter
[19:34:25] 250 Directory successfully changed.
[19:34:25] PWD
[19:34:25] 257 "/data/home/lu/alu/s121058/Mine dokumenter"
[19:34:25] TYPE A
[19:34:25] 200 Switching to ASCII mode.
[19:34:25] PASV
[19:34:25] 227 Entering Passive Mode (158,36,78,16,105,236)
[19:34:25] Opening data connection to Port: 27116
[19:34:25] LIST -laL
[19:34:25] 150 Here comes the directory listing.
[19:34:25] 2958 bytes transferred. (192 KB/s) (15 ms)
[19:34:25] 226 Directory send OK.
[19:35:16] NOOP
[19:35:16] 200 NOOP ok.

I'm also running vsFTPd and having the same problem with files that contain German "Umlauts" like

How can it be a server issue when I'm able to download the document using Internet Explorer (as an FTP client) or Total Commander's built-in FTP? (Although the file looks like this: ståle kjøreliste.xls, it's nonetheless able to download it.)

Hmm, the last time I've checked I wasn't able to download these files with another client either ... I'll check again.

Well, I just checked right now and I can download the document with both the above-mentioned programs.

Okay, the autodetection of the list encoding does not seem to work correctly. As a work-around, explicitly set "Default Code Page" to "UTF8" in the settings / favorite properties under "Transfer" -> "List Encoding".

BTW: I turned out that the problem I was having (see above) was another one / additional one to this autodetect bug.