550 Prohibited file name:

Hi. I've uploaded a file, and smartFTP wont let me delete it. There was a thread started about this before, but the starter left without leaving their solution.

[17:25:12] 550 Prohibited file name: Rachel in Mexico \'05.jpg

that's what i'm getting. does anyone know how i can fix this?


Hi, try to rename the file, if no luck, if you have Cpanel access you can try deleting with it if no, you must speak with your hosting.

what is Cpannel?

CPanel is a web-interface to configure your homepage / web-space that is provided by some hosts. If you don't know what it is, our host probably doesn't offer it, so just don't care :-) Instead, if you have have SSH shell access, log in via the shell and try to delete the file via command line.

my server doesnt seem to to support SSH.... any other ideas?

You could try to blend in the Command Line (View -> Panes) and delete the file manually by typing
DELE Rachel in Mexico \'05.jpg
DELE Rachel in Mexico '05.jpg
or variations of that (maybe even with wildcards).

[17:25:17]	 DELE Rachel in Mexico \'05.jpg

[17:25:17] 550 Prohibited file name: Rachel in Mexico \'05.jpg

that's the same error i keep on getting and its driving me bonkers

Have you tryed to rename the file? if no, ask your hosting to delete if for you.

Well, (') is a valid character in file names (at least on the filesystems I have in mind). The (\) is just to escape the (') so it won't be interpreted by the shell. However, this obviously is only necessary when working in a (SSH) shell on the command line, not via FTP. Something went really wrong here

This is an old topic, but I had the same problem (even when trying to use other FTP programs), so I employed the help of PHP:


$filename = '.pureftpd-upload.48a5e9d6.15.7608.f48a1251';


	echo "<p>File '$filename' deleted successfully.</p>";


	echo "<p>File '$filename' could not be deleted.</p>";


As expected, this worked without a hitch.