SSH

SmartFTP implementuje nasledujúce funkcie protokolu Secure Shell (SSH).

Funkcie

Súlad s bezpečnostnými štandardmi

Overovanie

Podporované sú nasledujúce metódy overovania:
  • Heslo
    Overovanie používateľským menom a heslom a interaktívne overovanie z klávesnice. Podporované sú aj požiadavky servera na zmenu hesla.
  • Verejný kľúč
    Súbor kľúča (PuTTY, VanDyke's SecureCRT, SSH.com, OpenSSH, PEM), certifikáty X.509, certifikáty Microsoft Windows z úložiska certifikátov alebo čipovej karty (PKCS #11).
  • Kerberos v5 (GSSAPI/SSPI)
    Podpora implementácií Microsoft Windows Kerberos (SSPI) a MIT Kerberos (GSSAPI).
  • Na základe hostiteľa
    Overovanie pomocou súboru kľúča hostiteľa alebo certifikátu.
  • RSA SecurID
    Dvojfaktorové overovanie RSA SecurID.

Šifrovanie

Kompresia

Metódy výmeny kľúčov

  • diffie-hellman-group14-sha1 (RFC 4253) (for compatibility)
  • diffie-hellman-group-exchange-sha1 (RFC 4419) (for compatibility)
  • diffie-hellman-group-exchange-sha256 (RFC 4419)
  • diffie-hellman-group14-sha256 (RFC 8268)
  • diffie-hellman-group16-sha512 (RFC 8268)
  • ecdh-sha2-nistp256 (RFC 6239)
  • ecdh-sha2-nistp384 (RFC 6239)
  • ecdh-sha2-nistp521 (RFC 6239)
  • curve25519-sha256 (RFC 9142)
  • curve25519-sha256@libssh.org (for compatibility)
  • mlkem768x25519-sha256 (RFC 10042)

Algoritmy verejných kľúčov

HMACs

Rozšírenia