SSH

SmartFTP реализует следующие возможности протокола Secure Shell (SSH).

Возможности

Соответствие стандартам безопасности

Аутентификация

Поддерживаются следующие методы проверки подлинности:
  • Пароль
    Аутентификация по имени пользователя и паролю, а также интерактивная аутентификация с клавиатуры. Поддерживаются запросы сервера на изменение пароля.
  • Открытый ключ
    Файлы ключей (PuTTY, VanDyke SecureCRT, SSH.com, OpenSSH, PEM), сертификаты X.509, сертификаты Microsoft Windows из хранилища сертификатов или смарт-карты (PKCS #11).
  • Kerberos v5 (GSSAPI/SSPI)
    Поддержка реализаций Microsoft Windows Kerberos (SSPI) и MIT Kerberos (GSSAPI).
  • На основе узла
    Аутентификация с помощью файла ключа узла или сертификата.
  • RSA SecurID
    Двухфакторная аутентификация RSA SecurID.

Шифрование

Сжатие

Методы обмена ключами

  • diffie-hellman-group14-sha1 (RFC 4253) (for compatibility)
  • diffie-hellman-group-exchange-sha1 (RFC 4419) (for compatibility)
  • diffie-hellman-group-exchange-sha256 (RFC 4419)
  • diffie-hellman-group14-sha256 (RFC 8268)
  • diffie-hellman-group16-sha512 (RFC 8268)
  • ecdh-sha2-nistp256 (RFC 6239)
  • ecdh-sha2-nistp384 (RFC 6239)
  • ecdh-sha2-nistp521 (RFC 6239)
  • curve25519-sha256 (RFC 9142)
  • curve25519-sha256@libssh.org (for compatibility)
  • mlkem768x25519-sha256 (RFC 10042)

Алгоритмы открытого ключа

HMACs

Расширения