SSH

SmartFTP gebruikt de geïntegreerde mogelijkheden van het Secure Shell (SSH) protocol.

Mogelijkheden

Naleving van beveiligingsstandaarden

Authenticatieq

De volgende authenticatiemethodes zijn toegestaan:
  • Wachtwoord
    Gebruikersnaam/wachtwoord en toetsenbord-interactieve authenticatie. Ondersteund ook serverwachtwoordwijzigingen.
  • Publieke code
    Key bestand (PuTTY, Vandyke's SecureCRT, SSH.com, OpenSSH, PEM), X.509-certificaten, Microsoft Windows certificaten van een certificaat op te slaan of een Smart Card (PKCS # 11).
  • Kerberos v5 (GSSAPI/SSPI)
    Ondersteuning voor Microsoft Windows Kerberos (SSPI) en MIT Kerberos (GSSAPI) implementatie.
  • Host Based
    Authenticatie met een host-sleutel bestand of een certificaat.
  • RSA SecurID
    RSA SecurID-tweefactorauthenticatie.

Encryptie

Compressies

Key Exchange Methods

  • diffie-hellman-group14-sha1 (RFC 4253) (for compatibility)
  • diffie-hellman-group-exchange-sha1 (RFC 4419) (for compatibility)
  • diffie-hellman-group-exchange-sha256 (RFC 4419)
  • diffie-hellman-group14-sha256 (RFC 8268)
  • diffie-hellman-group16-sha512 (RFC 8268)
  • ecdh-sha2-nistp256 (RFC 6239)
  • ecdh-sha2-nistp384 (RFC 6239)
  • ecdh-sha2-nistp521 (RFC 6239)
  • curve25519-sha256 (RFC 9142)
  • curve25519-sha256@libssh.org (for compatibility)
  • mlkem768x25519-sha256 (RFC 10042)

Publieke sleutel methoden

HMACs

Extensies