SSH

SmartFTP implementerer følgende funksjoner i SSH-protokollen (Secure Shell).

Funksjoner

Samsvar med sikkerhetsstandarder

Godkjenning

Følgende godkjenningsmetoder støttes:
  • Passord
    Brukernavn/passord og keyboard-interactive-godkjenning. Støtter også forespørsel om passordendring.
  • Fellesnøkkel
    Nøkkelfil (PuTTY, VanDyke's SecureCRT, SSH.com, OpenSSH, PEM), X.509-sertifikater, Microsoft Windows-sertifikater fra et sertifikatlager eller et smartkort (PKCS #11).
  • Kerberos v5 (GSSAPI/SSPI)
    Støtte for implementeringene Microsoft Windows Kerberos (SSPI) og MIT Kerberos (GSSAPI).
  • Vertsbasert
    Godkjenning med en vertsnøkkelfil eller et sertifikat.
  • RSA SecurID
    RSA SecurID-tofaktorautentisering.

Kryptering

Komprimering

Nøkkelutvekslingsmetoder

  • diffie-hellman-group14-sha1 (RFC 4253) (for compatibility)
  • diffie-hellman-group-exchange-sha1 (RFC 4419) (for compatibility)
  • diffie-hellman-group-exchange-sha256 (RFC 4419)
  • diffie-hellman-group14-sha256 (RFC 8268)
  • diffie-hellman-group16-sha512 (RFC 8268)
  • ecdh-sha2-nistp256 (RFC 6239)
  • ecdh-sha2-nistp384 (RFC 6239)
  • ecdh-sha2-nistp521 (RFC 6239)
  • curve25519-sha256 (RFC 9142)
  • curve25519-sha256@libssh.org (for compatibility)
  • mlkem768x25519-sha256 (RFC 10042)

Algoritmer for offentlig nøkkel

HMACs

Utvidelser