SSH

SmartFTP は、Secure Shell (SSH) プロトコルの以下の機能を実装しています。

機能

セキュリティ標準準拠

認証

次の認証方法がサポートされます。
  • パスワード
    ユーザー名/パスワード認証およびキーボード対話型認証。サーバー パスワード変更要求もサポートします。
  • 公開鍵
    キー ファイル (PuTTY、VanDyke's SecureCRT、SSH.com、OpenSSH、PEM)、X.509 証明書、証明書ストアまたはスマート カード (PKCS #11) からの Microsoft Windows 証明書。
  • Kerberos v5 (GSSAPI/SSPI)
    Microsoft Windows Kerberos (SSPI) および MIT Kerberos (GSSAPI) 実装をサポートします。
  • ホストベース
    ホスト キー ファイルまたは証明書による認証。
  • RSA SecurID
    RSA SecurID 二要素認証。

暗号化

圧迫

キー交換方法

  • diffie-hellman-group14-sha1 (RFC 4253) (for compatibility)
  • diffie-hellman-group-exchange-sha1 (RFC 4419) (for compatibility)
  • diffie-hellman-group-exchange-sha256 (RFC 4419)
  • diffie-hellman-group14-sha256 (RFC 8268)
  • diffie-hellman-group16-sha512 (RFC 8268)
  • ecdh-sha2-nistp256 (RFC 6239)
  • ecdh-sha2-nistp384 (RFC 6239)
  • ecdh-sha2-nistp521 (RFC 6239)
  • curve25519-sha256 (RFC 9142)
  • curve25519-sha256@libssh.org (for compatibility)
  • mlkem768x25519-sha256 (RFC 10042)

公開キー アルゴリズム

HMACs

拡張機能