SSH

SmartFTP a Secure Shell (SSH) protokoll következő funkcióit implementálja.

Jellemzők

Biztonsági szabvány megfelelőség

Hitelesítések

Az alábbi hitelesítési metódusok támogatottak:
  • Jelszó
    Felhasználónév/jelszó és ' keyboard-interactive authentication'. Továbbá támogatja a server jelszóváltaztatási kéréseket.
  • Publikus kulcs
    Kulcsfájlok (PuTTY, VanDyke's SecureCRT, SSH.com, OpenSSH, PEM), X.509-tanúsítványok, a tanúsítványtárból származó Microsoft Windows-tanúsítványok vagy intelligens kártyák (PKCS #11).
  • Kerberos v5 (GSSAPI/SSPI)
    Microsoft Windows Kerberos (SSPI) és MIT Kerberos (GSSAPI) támogatása.
  • Hoszt alapú
    Hitelesítés gazda kulcsfájllal vagy tanúsítvánnyal.
  • RSA SecurID
    RSA SecurID kétlépcsőz azonosítás.

Titkosítások

Tömörítések

Kulcscsere-módszerek

  • diffie-hellman-group14-sha1 (RFC 4253) (for compatibility)
  • diffie-hellman-group-exchange-sha1 (RFC 4419) (for compatibility)
  • diffie-hellman-group-exchange-sha256 (RFC 4419)
  • diffie-hellman-group14-sha256 (RFC 8268)
  • diffie-hellman-group16-sha512 (RFC 8268)
  • ecdh-sha2-nistp256 (RFC 6239)
  • ecdh-sha2-nistp384 (RFC 6239)
  • ecdh-sha2-nistp521 (RFC 6239)
  • curve25519-sha256 (RFC 9142)
  • curve25519-sha256@libssh.org (for compatibility)
  • mlkem768x25519-sha256 (RFC 10042)

Nyilvános kulcs algoritmusok

HMACs

Bővítmények