SSH

SmartFTP implementira sljedeće značajke protokola Secure Shell (SSH).

Značajke

Usklađenost sa sigurnosnim standardima

Provjere autentičnosti

Podržane su sljedeće metode provjere autentičnosti:
  • Lozinka
    Provjera autentičnosti korisničkim imenom/lozinkom i interaktivnim unosom putem tipkovnice. Podržava i zahtjeve poslužitelja za promjenu lozinke.
  • Javni ključ
    Datoteka ključa (PuTTY, VanDyke SecureCRT, SSH.com, OpenSSH, PEM), certifikati X.509, certifikati sustava Microsoft Windows iz spremišta certifikata ili pametna kartica (PKCS #11).
  • Kerberos v5 (GSSAPI/SSPI)
    Podrška za implementacije Microsoft Windows Kerberos (SSPI) i MIT Kerberos (GSSAPI).
  • Na temelju glavnog računala
    Provjera autentičnosti datotekom ključa glavnog računala ili certifikatom.
  • RSA SecurID
    Dvofaktorska provjera autentičnosti RSA SecurID.

Šifriranja

Komprimiranja

Metode razmjene ključeva

  • diffie-hellman-group14-sha1 (RFC 4253) (for compatibility)
  • diffie-hellman-group-exchange-sha1 (RFC 4419) (for compatibility)
  • diffie-hellman-group-exchange-sha256 (RFC 4419)
  • diffie-hellman-group14-sha256 (RFC 8268)
  • diffie-hellman-group16-sha512 (RFC 8268)
  • ecdh-sha2-nistp256 (RFC 6239)
  • ecdh-sha2-nistp384 (RFC 6239)
  • ecdh-sha2-nistp521 (RFC 6239)
  • curve25519-sha256 (RFC 9142)
  • curve25519-sha256@libssh.org (for compatibility)
  • mlkem768x25519-sha256 (RFC 10042)

Algoritmi javnog ključa

HMACs

Proširenja