SSH

SmartFTP implémente les fonctionnalités suivantes du protocole Secure Shell (SSH).

Fonctionnalités

Conformité aux normes de sécurité

Authentifications

Les méthodes d’authentification suivantes sont prises en charge :
  • Mot de passe
    Authentification par nom d’utilisateur/mot de passe et clavier interactif. Prend également en charge les demandes de changement de mot de passe du serveur.
  • Clé publique
    Fichier de clé (PuTTY, SecureCRT de VanDyke, SSH.com, OpenSSH, PEM), certificats X.509, certificats Microsoft Windows depuis un magasin de certificats ou une carte à puce (PKCS #11).
  • Kerberos v5 (GSSAPI/SSPI)
    Prise en charge des implémentations Microsoft Windows Kerberos (SSPI) et MIT Kerberos (GSSAPI).
  • Basée sur l’hôte
    Authentification avec un fichier de clé hôte ou d'un certificat.
  • RSA SecurID
    Authentification à deux facteurs RSA SecurID.

Chiffrement

Compressions

Méthodes d'échange de clés

  • diffie-hellman-group14-sha1 (RFC 4253) (for compatibility)
  • diffie-hellman-group-exchange-sha1 (RFC 4419) (for compatibility)
  • diffie-hellman-group-exchange-sha256 (RFC 4419)
  • diffie-hellman-group14-sha256 (RFC 8268)
  • diffie-hellman-group16-sha512 (RFC 8268)
  • ecdh-sha2-nistp256 (RFC 6239)
  • ecdh-sha2-nistp384 (RFC 6239)
  • ecdh-sha2-nistp521 (RFC 6239)
  • curve25519-sha256 (RFC 9142)
  • curve25519-sha256@libssh.org (for compatibility)
  • mlkem768x25519-sha256 (RFC 10042)

lgorithmes à clé publiques

HMACs

Extensions