425 Security: Bad IP connecting.

This forum is not monitored by the SmartFTP staff. To contact technical support see KB: How to request technical support.
Post Reply
bsnottum
Posts: 3
Joined: Mon Mar 28, 2005 7:53 pm

425 Security: Bad IP connecting.

Post by bsnottum » Mon Mar 28, 2005 8:06 pm

Hallo!

I am running smartFTP and are having problems connecting to a vsftp on a fedora fc3. The error code I get is: 425 Security: Bad IP connecting.

This is only a problem if I connect FTP over SSL. If I do normal FTP everything works just fine.

Are there additional settings I have to do in my router? All ports >1023 are already opened.

My ftp server is in the same local network as my work-machine, and if I try to connect FTP over SSL locally everything works seamless.

Here is a copy of the log I get:
SmartFTP v1.1.984.17
Resolving host name 80.202.193.104...
Connecting to (80.202.193.104) -> IP: 80.202.193.104 PORT: 21
Connected to (80.202.193.104) -> Time = 10ms
Socket connected waiting for login sequence.
220 Velkommen til ftp-serveren p

mb
Posts: 12026
Joined: Thu Oct 11, 2001 1:24 pm
Display name: Mat (SmartFTP)
Contact:

Re: 425 Security: Bad IP connecting.

Post by mb » Mon Mar 28, 2005 10:59 pm

Enable Settings->Connection "Force Server IP For PASV Mode"

Regards,
SmartFTP.com

bsnottum
Posts: 3
Joined: Mon Mar 28, 2005 7:53 pm

Re: 425 Security: Bad IP connecting.

Post by bsnottum » Tue Mar 29, 2005 7:27 am

Thanks a lot - that did it!!!!

I have one more question. I am trying to limit the port range in settings -> connection since my router are having problems to do NAT with ports >49000. Althoug I have limited the port range, the undesired ports are still in use by smartFTP.

Is there a way to solve this as well?

Sincerely,
Bjorn

Post Reply