DELE error with certain filenames

Locked
martini
Posts: 2
Joined: Thu May 29, 2003 4:11 pm

DELE error with certain filenames

Post by martini » Fri May 30, 2003 6:16 pm

im not sure this is a bug, or just the way it is, but heres the situation:

[14:06:41] 226 Transfer complete.
[14:06:45] DELE #oublinet.log
[14:06:45] 501 Invalid number of arguments.
[14:06:50] DELE #oublinet.log
[14:06:50] 501 Invalid number of arguments.

[14:06:58] DELE global.log
[14:06:58] 250 DELE command successful.
[14:06:58] DELE memoserv.log
[14:06:58] 250 DELE command successful.
[14:06:58] DELE moonbeam.log

trying to clean up my irssi log directory, and the # in the filename is being a pain.

misc info:

Code: Select all




client:



+- System -----------------------------



Microsoft Windows XP Professional 



Service Pack 1 (Build 2600)



CPU Speed         : 1594 MHz



Total Memory      : 522992 KB



Free Memory       : 296852 KB







+- SmartFTP ---------------------------



Version           : 1.0.976.7



Time Stamp        : 2003-05-18 00:35:32







+- Application DLL --------------------



Controls.dll      : 1.6.976.7



FTPAPI.dll        : 2.0.976.7



Language.dll      : 1.0.976.7



ResEng.dll        : 1.3.976.7







+- System DLL -------------------------



shell32.dll       : 6.00.2800.1145 (xpsp2.021108-1929)



shlwapi.dll       : 6.00.2800.1106 (xpsp1.020828-1920)



comctl32.dll      : 6.0 (xpsp1.020828-1920)



riched20.dll      : 5.30.23.1211



schannel.dll      : 5.1.2600.1106 (xpsp1.020828-1920)







+- Internet Explorer ------------------



Version           : 6.0.2800.1106







+- Winsock ----------------------------



Winsock           : 2.2















server:







root@eris:~# proftpd -vv -l



 -          Version: 1.2.8 (stable)



 - Scoreboard Version: 01040001



 -      Build Stamp: do mrt 22 18:28:32 CET 2001







Compiled-in modules:



  mod_core.c



  mod_xfer.c



  mod_auth_unix.c



  mod_auth_file.c



  mod_auth.c



  mod_ls.c



  mod_log.c



  mod_site.c



  mod_ratio.c



  mod_tls.c



  mod_rewrite.c



  mod_radius.c



  mod_wrap.c



  mod_auth_pam.c



  mod_readme.c



  mod_cap.c




if you need more info let me know.

my belief is it is just an escaping problem.

this isnt an urgent bug by any means, i can just delete with my shell account, but i thought it would be nice to submit it in case no one else does


-nk

mb
Posts: 12026
Joined: Thu Oct 11, 2001 1:24 pm
Display name: Mat (SmartFTP)
Contact:

Re: DELE error with certain filenames

Post by mb » Sat May 31, 2003 1:32 pm

Please post your license info (without the signature) for premium support.
Thanks.

martini
Posts: 2
Joined: Thu May 29, 2003 4:11 pm

Re: DELE error with certain filenames

Post by martini » Sun Jun 01, 2003 7:18 pm

-----BEGIN KEY-----
ID: 400001191
User: Nicholas Kuzmik
Company: zbi
Email: [hidden]
Version: 1.0
Number: 1
-----BEGIN SIGNATURE-----


sorry about that, didnt know i had to. i hid my email due to it being for my job (and they dont like people knowing) but i can send it in if you need me to.

-nk

mb
Posts: 12026
Joined: Thu Oct 11, 2001 1:24 pm
Display name: Mat (SmartFTP)
Contact:

Re: DELE error with certain filenames

Post by mb » Sun Jun 01, 2003 10:25 pm

The server expects quotes between the file names as far as I can see.
You define a custom command in Menu->Custom Commands->Edit Custom Commands

something like DELE "%ff"

Locked