Problem: Uploading to Filezilla server 0.9.44 causes REST loop

This forum is not monitored by the SmartFTP staff. To contact technical support see KB: How to request technical support.
Locked
nmg196
Posts: 6
Joined: Wed May 28, 2008 9:01 am

Problem: Uploading to Filezilla server 0.9.44 causes REST loop

Post by nmg196 » Wed May 14, 2014 9:52 am

Hi,
I thought I'd try SmartFTP for uploading to FileZilla server because of it's Mode Z support. However with everything on the default settings, transfers do not work.
 
This seems to be because the file size on the remote server seems to be the size of the compressed file, not the original file. As such Smart FTP seems to loop and just try uploading the file again.  
 
I can't determine if this is a bug in FileZilla not uncompressing the file when mode Z is used, or a problem with SmartFTP not properly flagging to FileZilla that it's a Mode Z file which needs decompressing. 
 
The logs show:
Source File Size=827392, Destination file size=782793
[09:40:13] Possible file size discrepancy found. Please contact the server administrator for assistance.
 
For full log for this transfer please see here: http://pastebin.com/n3UGY00M
 
Just wondering if this is fixable as Mode Z would be really useful for the type of content I transfer.
 
Thanks,
Nick

mb
Posts: 12026
Joined: Thu Oct 11, 2001 1:24 pm
Display name: Mat (SmartFTP)
Contact:

Re: Problem: Uploading to Filezilla server 0.9.44 causes REST loop

Post by mb » Wed May 14, 2014 12:45 pm


mb
Posts: 12026
Joined: Thu Oct 11, 2001 1:24 pm
Display name: Mat (SmartFTP)
Contact:

Re: Problem: Uploading to Filezilla server 0.9.44 causes REST loop

Post by mb » Tue May 27, 2014 3:26 am

The problem has been fixed in the latest version:
https://www.smartftp.com/download

Locked