Nothing shows on my homepage

This forum is not monitored by the SmartFTP staff. To contact technical support see KB: How to request technical support.
Eurydice
Posts: 17
Joined: Tue May 03, 2011 6:51 am

Nothing shows on my homepage

Post by Eurydice » Tue May 03, 2011 11:09 pm

Please help! I'm totally new at this, but thought I followed the SmartFTP tutorials, and everything happened exactly as they said with all the icons ending up in the remote browser window. BUT when I go the web address I used, I only get the message:

"Temporary homepage for account '...'
To replace this homepage, use your ftp account to replace the file "index.html" in your root directory. Note: your ftp user name is '...', and your ftp password is the password you supplied during the creation of your account".

I replaced the actual account and user names in the message with '...' for confidentiality reasons.

I'm using a grapevine web address and trying to upload a family tree web page output by the Legacy family history software. Maybe a bit complicated for a first attempt at a web page

mb
Posts: 12026
Joined: Thu Oct 11, 2001 1:24 pm
Display name: Mat (SmartFTP)
Contact:

Re: Nothing shows on my homepage

Post by mb » Tue May 03, 2011 11:16 pm

You need to replace the index.html/index.htm/default.htm etc with your start page.

Eurydice
Posts: 17
Joined: Tue May 03, 2011 6:51 am

Re: Nothing shows on my homepage

Post by Eurydice » Tue May 03, 2011 11:19 pm


You need to replace the index.html/index.htm/default.htm etc with your start page.

Eurydice
Posts: 17
Joined: Tue May 03, 2011 6:51 am

Re: Nothing shows on my homepage

Post by Eurydice » Tue May 03, 2011 11:23 pm

Wow! Thanks for incredibly quick response! Unfortunately I don't know what or where those are. I only got this far because of the really excellent illustrated step by step tutorials.
Is there another tutorial with pictures that explains?

Eurydice
Posts: 17
Joined: Tue May 03, 2011 6:51 am

Re: Nothing shows on my homepage

Post by Eurydice » Tue May 03, 2011 11:38 pm


You need to replace the index.html/index.htm/default.htm etc with your start page.

Eurydice
Posts: 17
Joined: Tue May 03, 2011 6:51 am

Re: Nothing shows on my homepage

Post by Eurydice » Tue May 03, 2011 11:48 pm

OK, trying to work it out. I can see things called "index html" and "index.htm" among all the stuff in the SmartFTP remote browser window, but nothing either there or in the "web" folder under "Legacy" in my C drive is called "Start page". Is that the front page I see when Legacy invites me to see my web page in my browser?

Eurydice
Posts: 17
Joined: Tue May 03, 2011 6:51 am

Re: Nothing shows on my homepage

Post by Eurydice » Wed May 04, 2011 1:08 am

Thanks for quick initial response mb, but don't quite know what it means or what to do next. Guess you don't have time to explain? Maybe SmartFTP is too smart for me.

mb
Posts: 12026
Joined: Thu Oct 11, 2001 1:24 pm
Display name: Mat (SmartFTP)
Contact:

Re: Nothing shows on my homepage

Post by mb » Wed May 04, 2011 1:41 am

Please purchase a license key and premium support will be able to assist you:
https://www.smartftp.com/buy/
Last edited by mb on Wed May 04, 2011 1:42 am, edited 1 time in total.

mb
Posts: 12026
Joined: Thu Oct 11, 2001 1:24 pm
Display name: Mat (SmartFTP)
Contact:

Re: Nothing shows on my homepage

Post by mb » Wed May 04, 2011 2:11 am

Try the following:
1. Delete the index.htm and index.html file on your server (in the Remote Browser)
2. Now refresh the root of your website in your browser. e.g. http://www.thisisyourpage.com/
3. You should see a 404 file not found error or similar (if not go back to 1).
4. Now in the folder on your computer (Local Browser / Explorer) which contains all the files of your website you want to upload there should be a file called index.html, index.htm, default.htm, default.html. If yes, then just upload everything and refresh the page in the browser. If there is no such file, rename the page you want to be displayed when visitors are going to root of your website to index.html and upload it.
Last edited by mb on Wed May 04, 2011 2:13 am, edited 1 time in total.

Eurydice
Posts: 17
Joined: Tue May 03, 2011 6:51 am

Re: Nothing shows on my homepage

Post by Eurydice » Wed May 04, 2011 2:23 am

OK mb, I paid Hope you're patient!
Regarding step 1, is this something I do in the SmartFTP screen, so I delete them from the remote browser there?

Post Reply