Delete Fails in Search Results

Locked
npiaseck
Posts: 5
Joined: Sun Jul 29, 2007 11:12 pm

Delete Fails in Search Results

Post by npiaseck » Tue May 12, 2009 8:08 pm

Steps To Reproduce
  1. Start SmartFTP v3.0.1027.0 and connect to a FileZilla server (in my case, via FTP over SSL) on Windows XP SP3.
  2. Navigate to a folder on the server that has many files in it via the remote browser.
  3. In the Search box in the remote browser's toolbar, enter a search phrase and press enter. A "Search 1" node appears with the filtered search results.
  4. Click on the "Search 1" node and select a file in the remote browser.
  5. Right-click the item and choose Delete. Press Yes to the confirmation dialog.
Expected Result
The item should be deleted.

Actual Result
One of the following occurs:
  • The operation fails silently.
  • Smart FTP crashes with the "encountered a problem and needs to close" Windows Error Reporting dialog. The faulting AppName is smartftp.exe. The faulting ModName is sfftpshellextension.dll at offset 00110de2.

mb
Posts: 12026
Joined: Thu Oct 11, 2001 1:24 pm
Display name: Mat (SmartFTP)
Contact:

Re: Delete Fails in Search Results

Post by mb » Tue May 12, 2009 8:12 pm

Thank you for the bug report. We are looking into it.

npiaseck
Posts: 5
Joined: Sun Jul 29, 2007 11:12 pm

Re: Delete Fails in Search Results

Post by npiaseck » Tue May 12, 2009 9:11 pm

I should add that deleting in the "normal" remote browser view works fine. It's only within the context of a search that it either fails silently or crashes (I assume that when it fails silently, it just corrupted its own memory space). Upon executing the Delete command, the Log pane doesn't update within any relevant commands, as if it never attempted to communicate with the server.

I can connect to some unspecified FTP server on a different host and the Search/Delete combination works fine. The FileZilla server version that exhibits the problem is 0.9.25. Other commands in the right-click menu for the Search pane work fine (such as "View" or "Open" or "Rename"); it's only "Delete" that has the problem. If it helps to note, the "Delete Multiple Items?" or "Delete File" confirmation prompt pops up every time, regardless of whether or not "Don't ask me again" is checked. Perhaps that dialog is failing in some way? I can only speculate. Hope that helps.

mb
Posts: 12026
Joined: Thu Oct 11, 2001 1:24 pm
Display name: Mat (SmartFTP)
Contact:

Re: Delete Fails in Search Results

Post by mb » Wed May 13, 2009 7:41 pm

The problem has been fixed in the latest version:
https://www.smartftp.com/download/

Thank you for reporting ;-)

Regards,
Mat

npiaseck
Posts: 5
Joined: Sun Jul 29, 2007 11:12 pm

Re: Delete Fails in Search Results

Post by npiaseck » Wed May 13, 2009 8:15 pm


mb
Posts: 12026
Joined: Thu Oct 11, 2001 1:24 pm
Display name: Mat (SmartFTP)
Contact:

Re: Delete Fails in Search Results

Post by mb » Wed May 13, 2009 9:23 pm

You are welcome. Thanks for the feedback ;-)

Locked