CWD not working?

Locked
Pastoweb
Posts: 66
Joined: Fri Nov 21, 2003 2:34 pm

CWD not working?

Post by Pastoweb » Fri May 23, 2008 4:04 pm

In the custom commands I imported from previous version the CWD command seems not to work.

+- System -----------------------------
Microsoft Windows XP Professional
Service Pack 2 (Build 2600)

CPU Speed : 1729 MHz
Total Memory : 2037 MB
Free Memory : 903 MB

+- SmartFTP ---------------------------
Version : 3.0.1016.7
Time Stamp : 2008-05-18 23:03:37
Platform : x86
Unlicensed
Days in use : 297

+- Application DLL --------------------
sfFTPLib.dll : 1.5.13.26
sfFavorites.dll : 1.0.12.7
sfFavoritesShellExtension.dll : 1.0.1.11
sfTransferQueue.dll : 1.0.9.7
sfFTPShellExtension.dll : 1.0.7.7

+- Language ---------------------------
SmartFTPITA.dll : 3.0.1016.3

+- Internet Explorer ------------------
Version : 7.0.5730.11

+- Winsock ----------------------------
Winsock : 2.2
Last edited by Pastoweb on Fri May 23, 2008 4:05 pm, edited 1 time in total.

mb
Posts: 12026
Joined: Thu Oct 11, 2001 1:24 pm
Display name: Mat (SmartFTP)
Contact:

Re: CWD not working?

Post by mb » Sat May 24, 2008 12:31 am

Can you please provide more details? What exactly are you doing and how does your custom command look like?

And please post the log as well.

Thank you.
Last edited by mb on Sat May 24, 2008 12:33 am, edited 1 time in total.

Pastoweb
Posts: 66
Joined: Fri Nov 21, 2003 2:34 pm

Re: CWD not working?

Post by Pastoweb » Sun May 25, 2008 5:01 pm

Can you please provide more details? What exactly are you doing and how does your custom command look like?

And please post the log as well.

Thank you.

the command is like this:

CWD ./administrator
SITE CHMOD 777 backups
SITE CHMOD 777 components
SITE CHMOD 777 modules
SITE CHMOD 777 templates
CWD ../
CWD %d/images
SITE CHMOD 777 banners
SITE CHMOD 777 stories
SITE CHMOD 777 content
...

the line "CWD ./administrator" is simply not executed (even writing "CWD %d/images"), it should call the sub folders inside the main dir

mb
Posts: 12026
Joined: Thu Oct 11, 2001 1:24 pm
Display name: Mat (SmartFTP)
Contact:

Re: CWD not working?

Post by mb » Sun May 25, 2008 8:57 pm

Please try it again with the latest version:
https://www.smartftp.com/download

It supports relative paths now.

Regards,
Mat

Locked