3.0.1015.5 does not handle z/OS HFS correctly

Locked
jeffdutton
Posts: 1
Joined: Wed Apr 09, 2008 3:34 pm

3.0.1015.5 does not handle z/OS HFS correctly

Post by jeffdutton » Sun May 04, 2008 5:02 pm

When connecting to a z/OS system MVS datasets are listed correctly. I no longer seem to be able to switch to HFS mode. When I enter CWD /tmp in the command window the log shows the following:

[indent][12:55:18] CWD 'TMP'
[12:55:18] 250 "TMP." is the working directory name prefix.
[12:55:18] PWD
[12:55:18] 257 "'TMP.'" is working directory.
[12:55:18] NOOP
[12:55:18] 200 OK
[/indent]

Note that the command seems to have been converted to CWD 'TMP'. The z/OS ftp server will interpret this as a request for an MVS dataset TMP. If the command origianlly sent in the command line where passed to the z/OS FTP as entered the fpt server would handle the request properly. Smartftp has been able to handle this in the past but each new version seems to re-introduce the problem.

I also note that once I have entered the command, that Smartftp appears to re-try it repeatedly as observed by the fact that the log sequence above is repeated about every 20 secs.

mb
Posts: 12026
Joined: Thu Oct 11, 2001 1:24 pm
Display name: Mat (SmartFTP)
Contact:

Re: 3.0.1015.5 does not handle z/OS HFS correctly

Post by mb » Sun May 04, 2008 11:34 pm

Hello ..

In the new version if you want to switch to HFS you need to set the initial path in the favorites settings. Then the first CWD command SmartFTP sends is exactly what you enter the Path input field without translating it. The problem with the NOOP command is related to the fact that the change directory failed.

Regards,
Mat

Locked