Remote Tree Not Refreshing

chrusion
Posts: 12
Joined: Fri Apr 11, 2008 5:07 pm

Remote Tree Not Refreshing

Post by chrusion » Sat Apr 19, 2008 2:16 am

Not an FTP or transfer que log issue, but more of a UI issue still present in build 1013.

In a remote viewer, create a new folder. Notice "New Folder" is displayed at the bottom of the remote's directory listing (right pane), but NOT in the tree view (left) pane. Highlight "New Folder" and rename to anything, ei "test." Notice in the tree view there still is no "test" folder.

Press F5 to refresh the dir. listing. Notice the "test" folder is now resorted and displayed among the other folders, BUT STILL DOES NOT APPEAR in the tree view.

Image

Image
Last edited by chrusion on Sat Apr 19, 2008 2:17 am, edited 1 time in total.

mb
Posts: 12026
Joined: Thu Oct 11, 2001 1:24 pm
Display name: Mat (SmartFTP)
Contact:

Re: Remote Tree Not Refreshing

Post by mb » Sat Apr 19, 2008 2:23 am

Please post the system information from the menu: Help->About "System Information:
Thanks.

sk90
Posts: 15
Joined: Fri Apr 18, 2008 3:53 pm

Re: Remote Tree Not Refreshing

Post by sk90 » Sat Apr 19, 2008 10:04 am

bei mir ist das selbe Problem, hier meine System-Informationen:

Code: Select all

+- System -----------------------------

Microsoft Windows XP Home Edition 

Service Pack 1 (Build 2600)



CPU Speed		   : 2992 MHz

Total Memory		: 2047 MB

Free Memory		 : 1428 MB



+- SmartFTP ---------------------------

Version			 : 3.0.1013.2

Time Stamp		  : 2008-04-16 11:14:04

Platform			: x86

Unlicensed

Days in use		 : 338



+- Application DLL --------------------

sfFTPLib.dll		: 1.5.13.1

sfFavorites.dll	 : 1.0.9.2

sfFavoritesShellExtension.dll : 1.0.1.9

sfTransferQueue.dll : 1.0.6.2

sfFTPShellExtension.dll : 1.0.4.2



+- Language ---------------------------

SmartFTPDEU.dll	 : 3.0.1013.2



+- Internet Explorer ------------------

Version			 : 6.0.2800.1106



+- Winsock ----------------------------

Winsock			 : 2.2

chrusion
Posts: 12
Joined: Fri Apr 11, 2008 5:07 pm

Re: Remote Tree Not Refreshing

Post by chrusion » Sat Apr 19, 2008 11:40 am

Original poster's info...


+- System -----------------------------
Microsoft Windows XP Professional
Service Pack 2 (Build 2600)

CPU Speed : 2589 MHz
Total Memory : 2047 MB
Free Memory : 1311 MB

+- SmartFTP ---------------------------
Version : 3.0.1013.0
Time Stamp : 2008-04-12 06:42:54
Platform : x86
Unlicensed
Days in use : 7

+- Application DLL --------------------
sfFTPLib.dll : 1.5.12.44
sfFavorites.dll : 1.0.9.0
sfFavoritesShellExtension.dll : 1.0.1.9
sfTransferQueue.dll : 1.0.6.0
sfFTPShellExtension.dll : 1.0.4.0

+- Language ---------------------------
SmartFTP.exe : 3.0.1013.0

+- Internet Explorer ------------------
Version : 7.0.5730.11

+- Winsock ----------------------------
Winsock : 2.2

mb
Posts: 12026
Joined: Thu Oct 11, 2001 1:24 pm
Display name: Mat (SmartFTP)
Contact:

Re: Remote Tree Not Refreshing

Post by mb » Sat Apr 19, 2008 11:59 am

Bug confirmed. We are working on a fix.

Thanks
Mat

mb
Posts: 12026
Joined: Thu Oct 11, 2001 1:24 pm
Display name: Mat (SmartFTP)
Contact:

Re: Remote Tree Not Refreshing

Post by mb » Mon Apr 21, 2008 12:48 am

Please try it with the latest version:
https://www.smartftp.com/download

We are not sure if we have addressed the bug in this version since we were no longer able to reproduce it.

Regards,
Mat

derril
Posts: 20
Joined: Sat May 19, 2007 4:32 pm

Re: Remote Tree Not Refreshing

Post by derril » Mon Apr 21, 2008 4:10 am

I have installed the new new version and I am still experiencing the same issue.

mb
Posts: 12026
Joined: Thu Oct 11, 2001 1:24 pm
Display name: Mat (SmartFTP)
Contact:

Re: Remote Tree Not Refreshing

Post by mb » Mon Apr 21, 2008 4:55 am

I'm sorry but bugs that we are unable to reproduce cannot be fixed. If you restart your computer does it work for some time?

Regards,
Mat

derril
Posts: 20
Joined: Sat May 19, 2007 4:32 pm

Re: Remote Tree Not Refreshing

Post by derril » Mon Apr 21, 2008 9:51 pm

Nope doesn't work even after restart. I did a restart immediately after installing the latest beta and not change.

The steps I'm doing are:

1. Open SmartFTP
2. Connect / Login
3. Add folder
-- folder does not show up in the tree
4. Close SmartFTP

1. Open SmartFTP
2. Connect / Login
-- folder exists that was created last time, in both the tree and file list
3. Delete folder, by click in the tree and clicking the button
-- tree still shows folder and stays in that folder in the file browser
4. Clicking on parent folder
-- folder not showing in file list
5. Refresh
-- no change (shows in tree, but not in file list)

I'm running 3.0.1013.8

Let me know if you need anything else.

chrusion
Posts: 12
Joined: Fri Apr 11, 2008 5:07 pm

Re: Remote Tree Not Refreshing

Post by chrusion » Tue Apr 22, 2008 4:29 am

1013.8 Tree Refresh Bug CONFIRMED per the steps above and those following below.

It appears you can force a tree refresh to show the added folder by double-clicking on the folder in the file list. This, of course, takes you inside the folder.

Next, go back up to the parent folder and rename the new folder in the file list. The folder name is then instantly updated in the tree.
Rename again, this time in the tree and the name change appears in the file list.

Next, delete the folder in file list. FTP commands sent:

[00:25:50] RMD test3
[00:25:50] 250 The directory was successfully removed

and the folder is removed from the file list, but still shows in the tree.

Next, try deleting the folder again... FTP log says
[00:10:41] RMD test3
[00:10:41] 550 Can't remove directory: No such file or directory

However, click on any other existing folder in the parent folder in the tree and FTP commands are issued to get the directory listing (assuming first time viewing, otherwise list is cached) as follows:

[00:17:40] CWD /tmp/cpu_exceeded_logs
[00:17:40] 250 OK. Current directory is /tmp/cpu_exceeded_logs
[00:17:40] PWD
[00:17:40] 257 "/tmp/cpu_exceeded_logs" is your current location
[00:17:40] TYPE A
[00:17:40] 200 TYPE is now ASCII
[00:17:40] PASV
[00:17:40] 227 Entering Passive Mode (69,89,21,61,68,182)
[00:17:40] Opening data connection to 69.89.21.61 Port: 17590
[00:17:40] LIST -aL
[00:17:40] 150 Accepted data connection
[00:17:40] 226-Options: -a -l
[00:17:40] 226 2 matches total
[00:17:40] 119 bytes transferred. (762 bytes/s) (156 ms)

Try doing that for the new folder... No ftp commands are sent since it's "directory listing" though empty, is cached. However, close the tab for the remote site, then reconnect (using entry in Favorites) and the deleted folder still appears, but now when you click on it in tree view, these ftp commands are sent...

[00:17:21] PWD
[00:17:21] 257 "/" is your current location
[00:17:21] CWD /tmp/test3
[00:17:21] 550 Can't change directory to /tmp/test3: No such file or directory

The only way to "clear the cached directory listing" is to exit and restart SFTP.

Locked