Class not registered error

This forum is not monitored by the SmartFTP staff. If you have a license please contact technical support by email.
Post Reply
brillerment
Posts: 5
Joined: Wed Jun 08, 2016 9:12 am

Class not registered error

Post by brillerment » Wed Jun 08, 2016 9:19 am

Hi
 
We recentily purchased a license for the library, and we managed to use this on our development box, however when moving across the our production environment, we get this error:
 
Retrieving the COM class factory for component with CLSID {52D6E699-9256-414F-8FCD-F38FDF6AC8EE} failed due to the following error: 80040154 Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG))
 
Any ideas what might fix this.
 
Regards,
Brent

mb
Posts: 12030
Joined: Thu Oct 11, 2001 1:24 pm
Display name: Mat (SmartFTP)
Contact:

Re: Class not registered error

Post by mb » Wed Jun 08, 2016 4:45 pm

regsvr32 sfFTPLib.dll
 
Or alternatively (better solution) if you build the executable, use SxS. Add the following to the manifest in the .exe:
 
   <dependency>
     <dependentAssembly>
        <assemblyIdentity
            type="win32"
            name="sfFTPLib"
            version="4.0.0.0"
            language="*"
            processorArchitecture="*" />
     </dependentAssembly>
  </dependency>
 
Documentation:
https://www.smartftp.com/static/ftplib/ ... ution.html
Last edited by mb on Wed Jun 08, 2016 11:00 pm, edited 1 time in total.

brillerment
Posts: 5
Joined: Wed Jun 08, 2016 9:12 am

Re: Class not registered error

Post by brillerment » Wed Jun 15, 2016 6:45 am

Hi
 
We're running this through a class library in a web service backend, so I don't think this really applies (there are no exe's).
 
Regards,
Brent

mb
Posts: 12030
Joined: Thu Oct 11, 2001 1:24 pm
Display name: Mat (SmartFTP)
Contact:

Re: Class not registered error

Post by mb » Wed Jun 15, 2016 3:56 pm

Then the first option applies:
regsvr32 sfFTPLib.dll
Last edited by mb on Wed Jun 15, 2016 4:06 pm, edited 1 time in total.

brillerment
Posts: 5
Joined: Wed Jun 08, 2016 9:12 am

Re: Class not registered error

Post by brillerment » Fri Jun 17, 2016 7:03 am

I've tried the first option running this in command prompt in admin mode (with the dll in system32 and in SysWOW64 directories), running the regsvr32 from each of those directories respectively, but I keep getting the error:

The module "sfFTPLib.dll" failed to load.
Make sure the binary is stored at the specified path or debug it to check for problems with the binary or dependant .DLL files.
The specified module could not be found.
 
Am I missing a dependency?

mb
Posts: 12030
Joined: Thu Oct 11, 2001 1:24 pm
Display name: Mat (SmartFTP)
Contact:

Re: Class not registered error

Post by mb » Sat Jun 18, 2016 7:44 am

It seems so. Make sure that you have copied all the files. See the list here:
https://www.smartftp.com/static/ftplib/ ... ation.html
Under paragraph Deployment
Did you install the c++ runtime (vcredist_x64.exe)?
Last edited by mb on Tue Jul 12, 2016 11:19 am, edited 1 time in total.

brillerment
Posts: 5
Joined: Wed Jun 08, 2016 9:12 am

Re: Class not registered error

Post by brillerment » Tue Jul 12, 2016 10:44 am

vcredist_x64 has already been installed, and the dlls are included, but we are still getting the same error. This is on Windows server 2012 R2 (64bit). Is there anything else I could be missing?

mb
Posts: 12030
Joined: Thu Oct 11, 2001 1:24 pm
Display name: Mat (SmartFTP)
Contact:

Re: Class not registered error

Post by mb » Tue Jul 12, 2016 11:18 am

Did yo copy the MUI folder en-us as well? The folder structure (en-us) must be retained.

brillerment
Posts: 5
Joined: Wed Jun 08, 2016 9:12 am

Re: Class not registered error

Post by brillerment » Wed Jul 13, 2016 11:28 am

MUI file and folder copied as well, still the same error.

Post Reply