Remote Edit Not Detecting Saves

Nick0r
Posts: 19
Joined: Sat Jun 18, 2011 6:14 pm

Remote Edit Not Detecting Saves

Post by Nick0r » Tue Sep 27, 2011 11:37 pm

Starting a new thread dedicated to this topic, as I know others have the same issue:

Hi,

The bug is extremely simple:

When using remote edit to edit files in Dreamweaver, sometimes when you have made changes and hit save, the Scheduler does not pick it up and auto-run. You have to re-save it again for it to happen.
It also happens often when you highlight say 5 files to remote edit at the same time, and then you are saving. It doesn't pick up some of the saves.

mb
Posts: 12030
Joined: Thu Oct 11, 2001 1:24 pm
Display name: Mat (SmartFTP)
Contact:

Re: Remote Edit Not Detecting Saves

Post by mb » Tue Sep 27, 2011 11:39 pm

Unable to reproduce. Please see the other thread for the information (reproducible case) we require to fix the problem.

jb78
Posts: 2
Joined: Wed Sep 28, 2011 10:09 am

Re: Remote Edit Not Detecting Saves

Post by jb78 » Wed Sep 28, 2011 10:17 am

I'm having the same issue by the sounds of it.

When i right click a file on the server and choose edit to remote edit the file it opens as normal in dreamweaver. When clicking save in dreamweaver it doesn't always pick up the save and upload the file to the server. Sometimes it will upload, sometimes it wont and have to save again (sometimes several times) to get smartftp to upload to the server.

Also if I have several files open for remote edit on some occasions when I click save i see one of the other open files being uploaded in the transfer queue.

System info is below

+- System -----------------------------
Microsoft Windows 7 Home Premium Edition
Service Pack 1 (Build 7601)

CPU Speed : 2094 MHz
Total Memory : 4063 MB
Free Memory : 1351 MB

+- SmartFTP ---------------------------
Version : 4.0.1216.0
Time Stamp : 2011-09-25 21:43:10
Platform : x64
Id : 400094656
Maintenance : 2012-08-24
Days in use : 600

+- Language ---------------------------
en-US

+- Internet Explorer ------------------
Version : 9.0.8112.16421

Nick0r
Posts: 19
Joined: Sat Jun 18, 2011 6:14 pm

Re: Remote Edit Not Detecting Saves

Post by Nick0r » Thu Sep 29, 2011 3:59 pm

I just saw today, SmartFTP when you have 2 files open in dreamweaver on remote edit. And you save one a few times, then go to the other and hit save, it actually tried saving the wrong one again.

mb
Posts: 12030
Joined: Thu Oct 11, 2001 1:24 pm
Display name: Mat (SmartFTP)
Contact:

Re: Remote Edit Not Detecting Saves

Post by mb » Sat Oct 01, 2011 6:18 am

Did you ever have the chance to reproduce this with another editor? e.g. notepad?

Nick0r
Posts: 19
Joined: Sat Jun 18, 2011 6:14 pm

Re: Remote Edit Not Detecting Saves

Post by Nick0r » Sat Oct 01, 2011 3:41 pm

I have not tried with other editors because Dreamweaver has always been used with SmartFTP for the past years and this only started happening about 2 versions ago.
I've also seen where I have two files open for remote editing, and save 1, it uploads the other.

Nick0r
Posts: 19
Joined: Sat Jun 18, 2011 6:14 pm

Re: Remote Edit Not Detecting Saves

Post by Nick0r » Sat Oct 01, 2011 4:37 pm

I think I may have steps to reproduce this error:

Highlight multiple files on ftp and right click remote edit (with Dreamweaver)

Edit one.... save it.
Then switch to a 2nd file, and save that one.
Repeat with other files if it doesn't happen then, but it will upload the 1st/wrong file at some point (happens often)

mb
Posts: 12030
Joined: Thu Oct 11, 2001 1:24 pm
Display name: Mat (SmartFTP)
Contact:

Re: Remote Edit Not Detecting Saves

Post by mb » Sat Oct 01, 2011 7:40 pm

I have found one issue: Files were uploaded right when the monitor started without them being modified. Maybe this is what you are seeing as well?

Nick0r
Posts: 19
Joined: Sat Jun 18, 2011 6:14 pm

Re: Remote Edit Not Detecting Saves

Post by Nick0r » Sat Oct 01, 2011 8:20 pm

That happens too, but it's not the problem described.

mb
Posts: 12030
Joined: Thu Oct 11, 2001 1:24 pm
Display name: Mat (SmartFTP)
Contact:

Re: Remote Edit Not Detecting Saves

Post by mb » Sat Oct 01, 2011 9:34 pm

I cannot reproduce the problem you have previously described. Can you try it with notepad?

Locked