Cannot setup a differnt editor to EDIT a remote file

Locked
ikraj
Posts: 2
Joined: Tue Sep 27, 2011 11:39 pm

Cannot setup a differnt editor to EDIT a remote file

Post by ikraj » Tue Sep 27, 2011 11:56 pm

I have tried to add Notepad++ to as my default remote editor for EDIT.

I am using the 64 bit home edition

I have done everything correctly as per your video and still whenever I try to open any .htm or .html files it defaults to MS Notepad as the editor.
Everything is setup correctly in the Tools > Seting > Remote Edit.

Why is it that SmartFTP does not recognize Notepad++ and it defaults to MS Notepad.

THe only way I can use Notepad++ is to use Edit with... and select Notepad++.

I will appreciate your help in fixing this problem
Last edited by ikraj on Wed Sep 28, 2011 1:51 am, edited 1 time in total.

mb
Posts: 12030
Joined: Thu Oct 11, 2001 1:24 pm
Display name: Mat (SmartFTP)
Contact:

Re: Cannot setup a differnt editor to EDIT a remote file

Post by mb » Wed Sep 28, 2011 1:51 am

Try to edit the file with Edit With..., then select the editor you want to use.

mb
Posts: 12030
Joined: Thu Oct 11, 2001 1:24 pm
Display name: Mat (SmartFTP)
Contact:

Re: Cannot setup a differnt editor to EDIT a remote file

Post by mb » Wed Sep 28, 2011 4:32 am

I'm unable to reproduce the problem. Here is how I have set it up:
- Tools - Settings. In the Remote Edit dialog, added .php extension. Set the editor to C:\Windows\write.exe
- Ensured that the Remote Edit option in the same dialog is set to "Editors, Shell Extensions"

Connected to server, right-clicked on a .php file. In the context menu I noticed that the Edit menu item now has the icon of write. Clicked on Edit and the file was downloaded and opened in write/WordPad.

Locked