Problem with Activex

This forum is not monitored by the SmartFTP staff. If you have a license please contact technical support by email.
Locked
advisor
Posts: 1
Joined: Sun Sep 18, 2005 11:45 pm

Problem with Activex

Post by advisor » Mon Sep 19, 2005 11:14 am

Now, I've a little program that can read the license key... (thanks for your great help...), but when I execute the program in another PC, I've this message:

Run-Time error '429'
ActiveX component can't create object
--------------------------------------------

I'm using Visual Basic 6 with Windows XP...
please, can help me again? whats is wrong??
Thanks!

mb
Posts: 12030
Joined: Thu Oct 11, 2001 1:24 pm
Display name: Mat (SmartFTP)
Contact:

Re: Problem with Activex

Post by mb » Mon Sep 19, 2005 6:31 pm

Try to register the component:

regsvr32.exe sfFTPLib.dll

peter@instantinterfaces.n
Posts: 3
Joined: Mon Oct 24, 2005 1:03 pm

Re: Problem with Activex

Post by peter@instantinterfaces.n » Mon Oct 24, 2005 1:14 pm

I have a similar problem.
In an App we have deployed we register DLL's on runtime. Suddenly (locally) the sFTP component can not be registered again.

When registering the component via regSvr32, the following error is produced:

DLLregister in sftpLib.dll has failed. Return code was 0x80070005

Other DDL's in the same dir are registering without problems.

On Googling the error, one of the possible reasons given for this error is "user rights". I checked those. (I am full Administrator on the development machine this error occurred)

the problem appeared on October 19, afternoon. That same morning (without restarts) it was still working well.

Any clue?

mb
Posts: 12030
Joined: Thu Oct 11, 2001 1:24 pm
Display name: Mat (SmartFTP)
Contact:

Re: Problem with Activex

Post by mb » Mon Oct 24, 2005 2:16 pm

Hello ..

For me it looks definitively like a permission problem. Please see the following link:
http://www.cryer.co.uk/brian/windows/tr ... 070005.htm

Regards,
-Mat

peter@instantinterfaces.n
Posts: 3
Joined: Mon Oct 24, 2005 1:03 pm

Re: Problem with Activex

Post by peter@instantinterfaces.n » Mon Nov 07, 2005 11:20 am

It was a permission problem, based on permissions in the registry on the keys connected to smartFTP

By manually resetting these permissions via regex32 (see link of moderator) and uninstalling the DLL, the problem was solved.

kstill
Posts: 5
Joined: Thu Sep 03, 2015 5:30 pm

Re: Problem with Activex

Post by kstill » Thu Sep 03, 2015 6:34 pm

How exactly did you reset these permissions? That link seems to be outdated now

Locked