Page 1 of 1

Director Listing Problem

Posted: Fri May 15, 2009 8:56 am
by jfm
I am currently using smartFtp version

v3.0 Build 1027.5 13. May 2009

and when smartFtp tries to do a listing with a directory wit a strange problem. The directory name is

The Invaders Part 3 (of 3) Season 2 E 15 - 26, Doppelgänger

and what is showing up in the directory listing is

The Invaders Part 3 (of 3) Season 2 E 15 - 26, Doppelg?drwxr-xr-x 2 admin administrators 4096 May 5 20:42 The Invaders[Season 1][1967]DvDrip[Eng]-McParts

It looks as if it has appended the rest of the 'ls' command and the next directory name th this one. The next directory

The Invaders[Season 1][1967]DvDrip[Eng]-McParts

does not show up in the list.

Regards
John Martin

Re: Director Listing Problem

Posted: Fri May 15, 2009 9:09 am
by mb
Hello John ..

Can you send us the raw directory listing to support@smartftp.com?

To get the raw directory listing, right-click on the folder and then select "Show Raw Listing" from the context menu.

Thanks
Mat

Re: Director Listing Problem

Posted: Fri May 15, 2009 11:02 am
by jfm
Hello John ..

Can you send us the raw directory listing to support@smartftp.com?

To get the raw directory listing, right-click on the folder and then select "Show Raw Listing" from the context menu.

Thanks
Mat

The raw listing is

drwxrwxrwx 7 admin administrators 4096 May 15 15:48 .
drwxrwxrwx 6 admin administrators 4096 Apr 13 12:42 ..
drwxr-xr-x 2 admin administrators 4096 May 12 22:22 The Invaders Part 2 (of 3) Season 2 E 1 - 14
drwxr-xr-x 2 admin administrators 4096 May 12 22:23 The Invaders Part 3 (of 3) Season 2 E 15 - 26, Doppelg?drwxr-xr-x 2 admin administrators 4096 May 5 20:42 The Invaders Season 1
drwxr-xr-x 2 admin administrators 4096 May 15 15:48 a MOMENT in june

Does that mean it is coming from the server like that.

john...

Re: Director Listing Problem

Posted: Fri May 15, 2009 11:06 am
by mb
Yep it looks like the bug is with the server.

Regards,
Mat

Re: Director Listing Problem

Posted: Fri May 15, 2009 11:15 am
by jfm
Yep it looks like the bug is with the server.

Regards,
Mat

OK, thanks for that. I didn't even know that 'Show Raw Listing' option was there. Anyway I changed the option CharsetRemote in the proftpd server from ASCII to UTF-8 and all is OK.

Thanks, john...