Strange first-drag fails to upload, second time works

Locked
skatterbrainz
Posts: 5
Joined: Mon Oct 08, 2007 4:12 am

Strange first-drag fails to upload, second time works

Post by skatterbrainz » Wed Jul 09, 2008 10:27 pm

Since 3.0, I've noticed a strange behavior where it now fails to actually replace an existing target file the first time I drag it from my local environment. This is on Vista Ultimate 32-bit. I choose the option to copy/replace the target file with the newer local file. It acts like it replaced it, but doesn't. The second time I drag the same file it actually replaces it. This happens "per file", not "per session". I have to be very careful now making sure files are getting updated each time I drag one to the remote folder. Nothing else has changed in my environment since SFTP 2.x, so the only thing I can pin this on is going to 3.0. Below is my system info from the SFTP console. I hope this can be resolved because this is very irritating and has already caused me some problems.

+- System -----------------------------
Microsoft Windows Vista Ultimate Edition
Service Pack 1 (Build 6001)

CPU Speed : 3059 MHz
Total Memory : 2047 MB
Free Memory : 2047 MB

+- SmartFTP ---------------------------
Version : 3.0.1019.7
Time Stamp : 2008-07-03 21:25:18
Platform : x86
Id : 400056842
Days in use : 139

+- Application DLL --------------------
sfFTPLib.dll : 1.5.13.32
sfFavorites.dll : 1.0.15.7
sfFavoritesShellExtension.dll : 1.0.1.13
sfTransferQueue.dll : 1.0.12.7
sfFTPShellExtension.dll : 1.0.10.7

+- Language ---------------------------
SmartFTP.exe : 3.0.1019.7

+- Internet Explorer ------------------
Version : 7.0.6001.18000

+- Winsock ----------------------------
Winsock : 2.2

skatterbrainz
Posts: 5
Joined: Mon Oct 08, 2007 4:12 am

Re: Strange first-drag fails to upload, second time works

Post by skatterbrainz » Wed Jul 09, 2008 10:30 pm

Just FYI - The system info reported in the SFTP "about" feature is incorrectly showing 2047 MB memory. I Have 4GB of RAM installed. I can verify this using Vista's utilities as well as third-party utilities.

mb
Posts: 12030
Joined: Thu Oct 11, 2001 1:24 pm
Display name: Mat (SmartFTP)
Contact:

Re: Strange first-drag fails to upload, second time works

Post by mb » Wed Jul 09, 2008 10:48 pm

Please install the latest version:
https://www.smartftp.com/download

Is the file added to the transfer queue the first time?

Regards,
Mat

skatterbrainz
Posts: 5
Joined: Mon Oct 08, 2007 4:12 am

Re: Strange first-drag fails to upload, second time works

Post by skatterbrainz » Fri Jul 11, 2008 12:43 am


Locked