Folder contents not displaying

Locked
lumdev
Posts: 2
Joined: Tue Jun 03, 2008 8:21 am

Folder contents not displaying

Post by lumdev » Tue Jun 03, 2008 8:43 am

Hi,

Since I've installed Version 3 on my pc I'm not able any more to open directories which contain a lot of files/directories (+/- 20.000). If I use an other ftp program I don't have any problem opening these folders, also with previous versions of SmartFTP I didn't encounter any problems.

I've already set the connection timeout to 2.000s.
Directory Listing Options (LIST Arguments) are all disabled.

Maybe there are other options I've got to change?

I've searched the forum but didn't see any reporting of this issue.

Greetings.


+- System -----------------------------
Microsoft Windows 2000 Professional
Service Pack 4 (Build 2195)

CPU Speed : 2659 MHz
Total Memory : 1015 MB
Free Memory : 515 MB

+- SmartFTP ---------------------------
Version : 3.0.1016.3
Time Stamp : 2008-05-12 21:59:01
Platform : x86
Unlicensed
Days in use : 307

+- Application DLL --------------------
sfFTPLib.dll : 1.5.13.24
sfFavorites.dll : 1.0.12.3
sfFavoritesShellExtension.dll : 1.0.1.9
sfTransferQueue.dll : 1.0.9.3
sfFTPShellExtension.dll : 1.0.7.3

+- Language ---------------------------
SmartFTP.exe : 3.0.1016.3

+- Internet Explorer ------------------
Version : 6.0.2800.1106

+- Winsock ----------------------------
Winsock : 2.2

phyburn
Posts: 2
Joined: Tue Jun 03, 2008 10:39 am

Re: Folder contents not displaying

Post by phyburn » Tue Jun 03, 2008 10:44 am

I seem to have the same problem. I can no longer see any folders or files... Every other FTP client works fine. Here is teh output:

[03:42:03] SmartFTP v3.0.1016.15
[03:42:10] Resolving host name
[03:42:10] Connecting to blah
[03:42:10] Connected to blah
[03:42:13] 220--------------------------------------------------------------------------------
[03:42:13] 220-
[03:42:13] 220-
[03:42:13] 220-
[03:42:13] 220-
[03:42:13] 220--------------------------------------------------------------------------------
[03:42:13] 220-
[03:42:13] 220 blah FTP server ready.
[03:42:13] USER blah
[03:42:14] 331 Password required for blah.
[03:42:14] PASS (hidden)
[03:42:14] 230-No directory! Logging in with home=/
[03:42:14] 230--------------------------------------------------------------------------------
[03:42:14] 230-
[03:42:14] 230-
[03:42:14] 230--------------------------------------------------------------------------------
[03:42:14] 230-
[03:42:14] 230 User blah logged in.
[03:42:14] SYST
[03:42:14] 215 UNIX Type: L8 Version: BSD-199506
[03:42:14] Detected Server Type: UNIX
[03:42:14] FEAT
[03:42:14] 211-Supported features:
[03:42:14] REST STREAM
[03:42:14] ADAT
[03:42:14] AUTH
[03:42:14] CCC
[03:42:14] CONF
[03:42:14] ENC
[03:42:14] MIC
[03:42:14] PBSZ
[03:42:14] PROT
[03:42:14] MDTM
[03:42:14] UTF8
[03:42:14] SIZE
[03:42:14] 211 End
[03:42:14] OPTS UTF8 ON
[03:42:15] 200 UTF-8 encoding enabled
[03:42:15] PWD
[03:42:15] 257 "/" is current directory.
[03:42:15] TYPE A
[03:42:15] 200 Type set to A.
[03:42:15] PASV
[03:42:15] 227 Entering Passive Mode (blah)
[03:42:15] Opening data connection to 7blah Port: 26368
[03:42:15] LIST -aL
[03:42:15] 150 Opening ASCII mode data connection for directory listing.
[03:42:15] 39 bytes transferred. (2.11 KB/s) (18 ms)
[03:42:15] 226 Transfer complete.

mb
Posts: 12029
Joined: Thu Oct 11, 2001 1:24 pm
Display name: Mat (SmartFTP)
Contact:

Re: Folder contents not displaying

Post by mb » Tue Jun 03, 2008 7:57 pm

lumdev: Install the latest version from https://www.smartftp.com/download. Then please post the complete log of your FTP session.

phyburn: Your problem is unrelated. Your serverver just returns an empty (39 bytes) directory listing. Try to remove the -a -L arguments from the LIST command. Favorites Settings. Then FTP->Transfer "Directory Listing Options"?

Regards
Mat
Last edited by mb on Tue Jun 03, 2008 7:57 pm, edited 1 time in total.

phyburn
Posts: 2
Joined: Tue Jun 03, 2008 10:39 am

Re: Folder contents not displaying

Post by phyburn » Tue Jun 03, 2008 11:25 pm


mb
Posts: 12029
Joined: Thu Oct 11, 2001 1:24 pm
Display name: Mat (SmartFTP)
Contact:

Re: Folder contents not displaying

Post by mb » Tue Jun 03, 2008 11:27 pm

Does the Mac OS X string appear anywhere in the welcome message? If yes we could automatically remove the -a -L options.

lumdev
Posts: 2
Joined: Tue Jun 03, 2008 8:21 am

Re: Folder contents not displaying

Post by lumdev » Wed Jun 04, 2008 9:29 am


mb
Posts: 12029
Joined: Thu Oct 11, 2001 1:24 pm
Display name: Mat (SmartFTP)
Contact:

Re: Folder contents not displaying

Post by mb » Wed Jun 04, 2008 1:10 pm

lumdev: I recommend you to use version 2.5 on Windodws 2000 because version 3.0 support for Windows 2000 is limited. You can get version 2.5 from: https://www.smartftp.com/support/kb/smar ... f2599.html

Locked