Page 1 of 2

Scheduler triggers not detecting new files

Posted: Wed Sep 14, 2011 11:14 pm
by alemieux
SmartFTP Version : 4.0.1210.0
OS Version : Microsoft Windows Server 2003 R2 Standard Ed. SP2

We updated SmartFTP about 1-2 weeks ago and we keep having issues with new files incoming to the monitored folder not being detected.... therefore never added to the Transfer Queue.

Here is my setup :
  • Two favorites connecting to the same FTP server
  • Each favorites have filters for specific file extension (#1 = TIFF and XML files / #2 = JPEG files)
  • Each favorites have are configured with a maximum of 1 worker
  • The transfer queue is limited to 2 worker
  • Two scheduler items monitoring the same folder H:\ToTransfer (That is shared with a remote computer who is dropping files there)
  • Each scheduler have 2 triggers : Instantiation + Monitor on the folder H:\ToTransfer
After restarting SmartFTP, the entire folder is checked against the FTP server and missing files are properly uploaded.... then all new files copied to the folder are properly added to the Queue.... BUT... after a while, the "Last Run Time" is way behind even if there is newer file in the folder. The triggers don't detect new files anymore.

Manually clicking "Run" from the contextual menu of each scheduler unblock it and items are added again to the Queue.... But it is still jammed and doesn't detect new files. I actually need to restart SmartFTP for the triggers to start working again.

It looks like the triggers monitoring the folder are crashing and the only way to get them back working is to restart SmartFTP.

Is this a know issue? Or any idea as to why the triggers stop working all of a sudden?

Another very interesting fact is that the trigger seems to often have its last run time set to 12:00 the day before when I look at it in the morning.

Thanks
Antoine Lemieux

Re: Scheduler triggers not detecting new files

Posted: Wed Sep 14, 2011 11:47 pm
by mb
Please try it again with the latest version: https://www.smartftp.com/download/

Re: Scheduler triggers not detecting new files

Posted: Fri Sep 16, 2011 3:50 pm
by Nick0r
Same for us - two seperate users experiencing the same issue of SmartFTP not getting every save.

Re: Scheduler triggers not detecting new files

Posted: Fri Sep 16, 2011 4:55 pm
by mb
>alemieux
We were able to reproduce the problem. A fix will be able in the next build. In addition we have added a "Last Run Result" column to the scheduler list control.

Re: Scheduler triggers not detecting new files

Posted: Sun Sep 25, 2011 8:43 pm
by mb
The new version is available now: https://www.smartftp.com/download/

Re: Scheduler triggers not detecting new files

Posted: Sun Sep 25, 2011 8:54 pm
by Nick0r
Hi,

Just checked that page it shows thes ame version as before. Is there a delay until it is available?

Re: Scheduler triggers not detecting new files

Posted: Sun Sep 25, 2011 10:39 pm
by mb
For me it shows Build 1216

Re: Scheduler triggers not detecting new files

Posted: Mon Sep 26, 2011 6:21 pm
by Nick0r
After playing with the new build some more this morning - it is still not accurately picking up every version of a 'Save' for remote editing. E.g. The Run is not automatically taking place on every save.

Re: Scheduler triggers not detecting new files

Posted: Mon Sep 26, 2011 6:44 pm
by mb
>nksftp
The new build fixes the problem alemieux has reported. Your problem is unrelated and we are unable to reproduce it. Please provide detailed instructions on how to reproduce it on a fresh installation of Windows 7 with minimal configuration changes.

Re: Scheduler triggers not detecting new files

Posted: Mon Sep 26, 2011 8:29 pm
by Nick0r
Hi,

The bug is extremely simple:

When using remote edit to edit files in Dreamweaver, sometimes when you have made changes and hit save, the Scheduler does not pick it up and auto-run. You have to re-save it again for it to happen.